summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-09-26 20:19:08 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-02 10:54:40 +0000
commitc6843609bde8ce592ca18e2dbecfa577525153e8 (patch)
treee3ad9aeb085adc315f25bba8fc5f9f253681acab /gnu
parent2ec38cbce0825e32ede4dcfd192fa40ffe510b22 (diff)
downloadguix-patches-c6843609bde8ce592ca18e2dbecfa577525153e8.tar
guix-patches-c6843609bde8ce592ca18e2dbecfa577525153e8.tar.gz
gnu: devhelp: Update to 40.1.
* gnu/packages/gnome.scm (devhelp): Update to 40.1. [source]: Fix the URI. [arguments]: Remove trailing #t.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b47b9c03ef..0732c8151d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5674,15 +5674,15 @@ both a traditional UI or a modern UI with a GtkHeaderBar.")
(define-public devhelp
(package
(name "devhelp")
- (version "3.34.0")
+ (version "40.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
- (version-major+minor version) "/"
+ (version-major version) "/"
name "-" version ".tar.xz"))
(sha256
(base32
- "0zpmn6fgkgiayvn4diia5df0s6s7dqrdnp3nrvpavsmgn0vhb4pg"))))
+ "1fvb69l1nyxdrs95ar95rmpfs8nfkpys4x74r8ilid44hhzdk2iy"))))
(build-system meson-build-system)
(arguments
'(#:glib-or-gtk? #t
@@ -5692,8 +5692,7 @@ both a traditional UI or a modern UI with a GtkHeaderBar.")
;; Don't create 'icon-theme.cache'.
(lambda _
(substitute* "meson_post_install.py"
- (("gtk-update-icon-cache") "true"))
- #t)))))
+ (("gtk-update-icon-cache") "true")))))))
(native-inputs
`(("intltool" ,intltool)
("itstool" ,itstool)