summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-05-17 12:22:49 +0200
committerLudovic Courtès <ludo@gnu.org>2015-05-17 14:12:22 +0200
commitc466bfd1ac8a3843acd0ce77453bba04323c4a8b (patch)
treed6237be8d7464c0faeb18f6a81bd99fb262d9cc1 /gnu
parent2f910ef68c1852b32b9ef27535ddbaa7ede3401b (diff)
downloadguix-patches-c466bfd1ac8a3843acd0ce77453bba04323c4a8b.tar
guix-patches-c466bfd1ac8a3843acd0ce77453bba04323c4a8b.tar.gz
gnu: magit: Use 'modify-phases'.
* gnu/packages/emacs.scm (magit)[arguments]: Use 'modify-phases' instead of 'alist-cons-before' & co.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm36
1 files changed, 18 insertions, 18 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index a1366efe8f..5c6d3c16c6 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -298,28 +298,28 @@ configuration files, such as .gitattributes, .gitignore, and .git/config.")
(guix build emacs-utils))
#:tests? #f ; no check target
#:phases
- (alist-replace
- 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (substitute* "Makefile"
- (("/usr/local") out)
- (("/etc") (string-append out "/etc")))))
- (alist-cons-before
- 'build 'patch-exec-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((git (assoc-ref inputs "git"))
- (git:gui (assoc-ref inputs "git:gui")))
- (emacs-substitute-variables "magit.el"
- ("magit-git-executable" (string-append git "/bin/git"))
- ("magit-gitk-executable" (string-append git:gui "/bin/gitk")))))
- (alist-cons-after
+ (modify-phases %standard-phases
+ (replace
+ 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "Makefile"
+ (("/usr/local") out)
+ (("/etc") (string-append out "/etc"))))))
+ (add-before
+ 'build 'patch-exec-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((git (assoc-ref inputs "git"))
+ (git:gui (assoc-ref inputs "git:gui")))
+ (emacs-substitute-variables "magit.el"
+ ("magit-git-executable" (string-append git "/bin/git"))
+ ("magit-gitk-executable" (string-append git:gui "/bin/gitk"))))))
+ (add-after
'install 'post-install
(lambda* (#:key outputs #:allow-other-keys)
(emacs-generate-autoloads
,name (string-append (assoc-ref outputs "out")
- "/share/emacs/site-lisp/")))
- %standard-phases)))))
+ "/share/emacs/site-lisp/")))))))
(home-page "http://magit.github.io/")
(synopsis "Emacs interface for the Git version control system")
(description