summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-04-04 14:40:37 +0200
committerLudovic Courtès <ludo@gnu.org>2019-04-04 17:47:01 +0200
commitc44667ccae7581cb2a18a8f25d8e867bd352194d (patch)
treeba8df536f0138b4df934a691d61a27cc2be1e0c7 /gnu
parentaea505a928d1274bc2186ce3c95f707b9c982757 (diff)
downloadguix-patches-c44667ccae7581cb2a18a8f25d8e867bd352194d.tar
guix-patches-c44667ccae7581cb2a18a8f25d8e867bd352194d.tar.gz
gnu: ghc-tls: Move to haskell-crypto.scm.
* gnu/packages/tls.scm (ghc-tls): Move to... * gnu/packages/haskell-crypto.scm (ghc-tls): ... here. * gnu/packages/haskell-web.scm: Remove now unneeded import.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell-crypto.scm43
-rw-r--r--gnu/packages/haskell-web.scm1
-rw-r--r--gnu/packages/tls.scm46
3 files changed, 43 insertions, 47 deletions
diff --git a/gnu/packages/haskell-crypto.scm b/gnu/packages/haskell-crypto.scm
index 8f216a379d..8d28a77fc1 100644
--- a/gnu/packages/haskell-crypto.scm
+++ b/gnu/packages/haskell-crypto.scm
@@ -733,3 +733,46 @@ It also includes support for detached signatures, and thorough
documentation on the design and implementation, including usage
guidelines.")
(license license:expat)))
+
+(define-public ghc-tls
+ (package
+ (name "ghc-tls")
+ (version "1.4.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "tls/tls-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1y083724mym28n6xfaz7pcc7zqxdhjpaxpbvzxfbs25qq2px3smv"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-cereal" ,ghc-cereal)
+ ("ghc-data-default-class" ,ghc-data-default-class)
+ ("ghc-memory" ,ghc-memory)
+ ("ghc-cryptonite" ,ghc-cryptonite)
+ ("ghc-asn1-types" ,ghc-asn1-types)
+ ("ghc-asn1-encoding" ,ghc-asn1-encoding)
+ ("ghc-x509" ,ghc-x509)
+ ("ghc-x509-store" ,ghc-x509-store)
+ ("ghc-x509-validation" ,ghc-x509-validation)
+ ("ghc-async" ,ghc-async)
+ ("ghc-network" ,ghc-network)
+ ("ghc-hourglass" ,ghc-hourglass)))
+ (native-inputs
+ `(("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)
+ ("ghc-quickcheck" ,ghc-quickcheck)))
+ (home-page "https://github.com/vincenthz/hs-tls")
+ (synopsis
+ "TLS/SSL protocol native implementation (Server and Client)")
+ (description
+ "Native Haskell TLS and SSL protocol implementation for server and client.
+This provides a high-level implementation of a sensitive security protocol,
+eliminating a common set of security issues through the use of the advanced
+type system, high level constructions and common Haskell features. Currently
+implement the SSL3.0, TLS1.0, TLS1.1 and TLS1.2 protocol, and support RSA and
+Ephemeral (Elliptic curve and regular) Diffie Hellman key exchanges, and many
+extensions.")
+ (license license:bsd-3)))
+
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 38797e6535..555fee12d4 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -27,7 +27,6 @@
#:use-module (gnu packages haskell)
#:use-module (gnu packages haskell-check)
#:use-module (gnu packages haskell-crypto)
- #:use-module (gnu packages tls)
#:use-module (guix build-system haskell)
#:use-module (guix download)
#:use-module ((guix licenses) #:prefix license:)
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index c0b92bab04..3d579440b0 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -38,7 +38,6 @@
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
#:use-module (guix build-system cmake)
- #:use-module (guix build-system haskell)
#:use-module (guix build-system trivial)
#:use-module (gnu packages compression)
#:use-module (gnu packages)
@@ -48,9 +47,6 @@
#:use-module (gnu packages dns)
#:use-module (gnu packages gawk)
#:use-module (gnu packages guile)
- #:use-module (gnu packages haskell)
- #:use-module (gnu packages haskell-check)
- #:use-module (gnu packages haskell-crypto)
#:use-module (gnu packages libbsd)
#:use-module (gnu packages libffi)
#:use-module (gnu packages libidn)
@@ -882,48 +878,6 @@ coding footprint.")
#t)))
,@(package-arguments mbedtls-apache)))))))
-(define-public ghc-tls
- (package
- (name "ghc-tls")
- (version "1.4.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://hackage.haskell.org/package/"
- "tls/tls-" version ".tar.gz"))
- (sha256
- (base32
- "1y083724mym28n6xfaz7pcc7zqxdhjpaxpbvzxfbs25qq2px3smv"))))
- (build-system haskell-build-system)
- (inputs
- `(("ghc-cereal" ,ghc-cereal)
- ("ghc-data-default-class" ,ghc-data-default-class)
- ("ghc-memory" ,ghc-memory)
- ("ghc-cryptonite" ,ghc-cryptonite)
- ("ghc-asn1-types" ,ghc-asn1-types)
- ("ghc-asn1-encoding" ,ghc-asn1-encoding)
- ("ghc-x509" ,ghc-x509)
- ("ghc-x509-store" ,ghc-x509-store)
- ("ghc-x509-validation" ,ghc-x509-validation)
- ("ghc-async" ,ghc-async)
- ("ghc-network" ,ghc-network)
- ("ghc-hourglass" ,ghc-hourglass)))
- (native-inputs
- `(("ghc-tasty" ,ghc-tasty)
- ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)
- ("ghc-quickcheck" ,ghc-quickcheck)))
- (home-page "https://github.com/vincenthz/hs-tls")
- (synopsis
- "TLS/SSL protocol native implementation (Server and Client)")
- (description
- "Native Haskell TLS and SSL protocol implementation for server and client.
-This provides a high-level implementation of a sensitive security protocol,
-eliminating a common set of security issues through the use of the advanced
-type system, high level constructions and common Haskell features. Currently
-implement the SSL3.0, TLS1.0, TLS1.1 and TLS1.2 protocol, and support RSA and
-Ephemeral (Elliptic curve and regular) Diffie Hellman key exchanges, and many
-extensions.")
- (license license:bsd-3)))
-
(define-public dehydrated
(package
(name "dehydrated")