summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndré A. Gomes <andremegafone@gmail.com>2022-09-06 23:22:42 +0300
committerGuillaume Le Vaillant <glv@posteo.net>2022-09-07 14:32:09 +0200
commitc02450c2373ad8b60b93a67bab6891b4321e34b3 (patch)
tree2677cff086f046f5aae0e5d4cc4ef9a3ad595ad8 /gnu
parentd4eeb77aae599b69caa8834189219d04c376d585 (diff)
downloadguix-patches-c02450c2373ad8b60b93a67bab6891b4321e34b3.tar
guix-patches-c02450c2373ad8b60b93a67bab6891b4321e34b3.tar.gz
gnu: cl-lisp-unit2: Update to 0.9.3.
* gnu/packages/lisp-check.scm (sbcl-lisp-unit2): Update to 0.9.3. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp-check.scm46
1 files changed, 22 insertions, 24 deletions
diff --git a/gnu/packages/lisp-check.scm b/gnu/packages/lisp-check.scm
index cf5bdbd840..d3f43a4f60 100644
--- a/gnu/packages/lisp-check.scm
+++ b/gnu/packages/lisp-check.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021 Charles Jackson <charles.b.jackson@protonmail.com>
;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2022 André A. Gomes <andremegafone@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -572,32 +573,29 @@ testing. It is an extension of the library written by Chris Riesbeck.")
(define-public sbcl-lisp-unit2
;; There is a cyclical dependency between symbol-munger and lisp-unit2.
;; See https://github.com/AccelerationNet/symbol-munger/issues/4
- (let ((commit "fb9721524d1e4e73abb223ee036d74ce14a5505c")
- (revision "1"))
- (package
- (name "sbcl-lisp-unit2")
- (version (git-version "0.2.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/AccelerationNet/lisp-unit2")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1rsqy8y0jqll6xn9a593848f5wvd5ribv4csry1ly0hmdhfnqzlp"))))
- (build-system asdf-build-system/sbcl)
- (inputs
- (list sbcl-alexandria sbcl-cl-interpol sbcl-iterate
- sbcl-symbol-munger))
- (synopsis "Test Framework for Common Lisp")
- (description
- "LISP-UNIT2 is a Common Lisp library that supports unit testing in the
+ (package
+ (name "sbcl-lisp-unit2")
+ (version "0.9.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/AccelerationNet/lisp-unit2")
+ (commit version)))
+ (file-name (git-file-name "cl-lisp-unit2" version))
+ (sha256
+ (base32 "0y7k6fd4mf7ggc8kdrbg8flkj5j7i7ki1350wnj6hqax7cmh4xv5"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ (list sbcl-alexandria sbcl-cl-interpol sbcl-iterate
+ sbcl-symbol-munger))
+ (synopsis "Test Framework for Common Lisp")
+ (description
+ "LISP-UNIT2 is a Common Lisp library that supports unit testing in the
style of JUnit for Java. It is a new version of the lisp-unit library written
by Chris Riesbeck.")
- (home-page "https://github.com/AccelerationNet/lisp-unit2")
- (license license:expat))))
+ (home-page "https://github.com/AccelerationNet/lisp-unit2")
+ (license license:expat)))
(define-public cl-lisp-unit2
(sbcl-package->cl-source-package sbcl-lisp-unit2))