summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-06-03 17:43:24 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-06-06 02:38:26 -0400
commitbc11792923bc42053800a442661def8ed91223da (patch)
tree85140b6929bad4faa7e98fe8f7d20b9af674177b /gnu
parent2e79f847fdd771067493c25e1d9154df221a28b8 (diff)
downloadguix-patches-bc11792923bc42053800a442661def8ed91223da.tar
guix-patches-bc11792923bc42053800a442661def8ed91223da.tar.gz
gnu: Add rust-crypto-hash-0.3.
* gnu/packages/crates-io.scm (rust-crypto-hash-0.3): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index da8a657fd2..d72c2d4d8a 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -10108,6 +10108,34 @@ Code (MAC) algorithms.")
algorithms.")
(license (list license:expat license:asl2.0))))
+(define-public rust-crypto-hash-0.3
+ (package
+ (name "rust-crypto-hash")
+ (version "0.3.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "crypto-hash" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1jnxgpk0j29hzcv42viq5dckyfjnxdjsar55366j95zx80i1cxwa"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-commoncrypto" ,rust-commoncrypto-0.2)
+ ("rust-hex" ,rust-hex-0.3)
+ ("rust-openssl" ,rust-openssl-0.10)
+ ("rust-winapi" ,rust-winapi-0.3))))
+ (inputs
+ `(("openssl" ,openssl)))
+ (home-page "https://github.com/malept/crypto-hash")
+ (synopsis "Wrapper for OS-level cryptographic hash functions")
+ (description "This package provides a wrapper for OS-level cryptographic
+hash functions.")
+ (license license:expat)))
+
(define-public rust-cryptovec-0.4
(package
(name "rust-cryptovec")