summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-07-25 16:05:10 -0400
committerLudovic Courtès <ludo@gnu.org>2022-08-09 16:57:49 +0200
commitbc03aa438bef326d47aafaed99bc6de45e518c53 (patch)
tree13b617fc3151f30cc020d5acb7f785e36f784368 /gnu
parent60e0aae89cbf29f88f110376f911777aac70e8a7 (diff)
downloadguix-patches-bc03aa438bef326d47aafaed99bc6de45e518c53.tar
guix-patches-bc03aa438bef326d47aafaed99bc6de45e518c53.tar.gz
gnu: wrap-python3: Clarify relationship with wrapped package.
The previous description could give the impression that the user faced a choice between `python` and `python3`, but could not have both at once. In fact, the packages `python-wrapper` and `python-minimal-wrapper` already provide both sets of names. * gnu/packages/python.scm (wrap-python3)[description]: Tweak. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4fcee28ba3..23407e4e84 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -58,6 +58,7 @@
;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2020, 2021 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -662,10 +663,13 @@ for more information.")))
(synopsis "Wrapper for the Python 3 commands")
(description
"This package provides wrappers for the commands of Python@tie{}3.x such
-that they can be invoked under their usual name---e.g., @command{python}
+that they can also be invoked under their usual names---e.g., @command{python}
instead of @command{python3} or @command{pip} instead of @command{pip3}.
+
To function properly, this package should not be installed together with the
-@command{python} package.")))
+@code{python} package: this package uses the @code{python} package as a
+propagated input, so installing this package already makes both the versioned
+and the unversioned commands available.")))
(define-public python-wrapper (wrap-python3 python))
(define-public python-minimal-wrapper (wrap-python3 python-minimal))