summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBrennan Vincent <brennan@umanwizard.com>2024-02-17 13:35:16 -0500
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-29 09:35:58 +0100
commitbbb1a7b5edeba943c74dc6a15dd9cf11cc2af515 (patch)
tree3552029c0441914d8a092a1598e8dfba52e6d6c1 /gnu
parent0bce74d458a343e61d054c4b25d6f67bd1086f3c (diff)
downloadguix-patches-bbb1a7b5edeba943c74dc6a15dd9cf11cc2af515.tar
guix-patches-bbb1a7b5edeba943c74dc6a15dd9cf11cc2af515.tar.gz
gnu: Add go-1.22 and its standard library.
* gnu/packages/golang.scm (go-1.22): New variable. * gnu/packages/golang.scm (go-std-1.22): New variable. Change-Id: I18d92874d4131843e7c6cf0e8d89f2946f7b972d Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3fd844c7a0..b8ac0983af 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -45,6 +45,7 @@
;;; Copyright © 2023 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
;;; Copyright © 2024 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2024 Brennan Vincent <brennan@umanwizard.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1114,6 +1115,38 @@ in the style of communicating sequential processes (@dfn{CSP}).")
("api" "share/go/api" ,tests)
("test" "share/go/test" ,tests))))))))))))
+(define-public go-1.22
+ (package
+ (inherit go-1.21)
+ (name "go")
+ (version "1.22.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/golang/go")
+ (commit (string-append "go" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "00j6sn2zysk5pdzxw1wfdi31wggzw1h1026ah3x3mi85dwsijhjs"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments go-1.21)
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (replace 'unpatch-perl-shebangs
+ (lambda _
+ ;; Avoid inclusion of perl in closure by rewriting references
+ ;; to perl input in sourcecode generators and test scripts
+ (substitute* (find-files "src" "\\.pl$")
+ (("^#!.*")
+ "#!/usr/bin/env perl\n"))))))))
+ (native-inputs
+ ;; Go 1.22 and later requires Go 1.20 (min. 1.20.6, which we don't have)
+ ;; as the bootstrap toolchain.
+ (alist-replace "go"
+ (list go-1.21)
+ (package-native-inputs go-1.21)))))
+
(define-public go go-1.17)
(define make-go-std
@@ -1157,6 +1190,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
(define-public go-std-1.19 (make-go-std go-1.19))
(define-public go-std-1.20 (make-go-std go-1.20))
(define-public go-std-1.21 (make-go-std go-1.21))
+(define-public go-std-1.22 (make-go-std go-1.22))
(define-public go-0xacab-org-leap-shapeshifter
(let ((commit "0aa6226582efb8e563540ec1d3c5cfcd19200474")