summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-11-07 12:50:37 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-11-07 12:50:37 +0200
commitbb7ff88ff215f76e2c5f7640890e21fcb31b55ea (patch)
tree5814418ada25a4aeeb311d5cf44d1d5c4a9fc0ca /gnu
parentf0c6810007ffafeab4e498df8e78df310afb50bc (diff)
downloadguix-patches-bb7ff88ff215f76e2c5f7640890e21fcb31b55ea.tar
guix-patches-bb7ff88ff215f76e2c5f7640890e21fcb31b55ea.tar.gz
gnu: epiphany: Don't build icon cache.
* gnu/packages/gnome.scm (epiphany)[arguments]: Add phase to skip creating gtk icon cache. [native-inputs]: Remove gtk+:bin.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 1e8dc77912..cc04b9d65a 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4487,6 +4487,14 @@ a secret password store, an adblocker, and a modern UI.")
;; FAIL
'(#:tests? #f
#:glib-or-gtk? #t
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ ;; Don't create 'icon-theme.cache'.
+ (lambda _
+ (substitute* "post_install.py"
+ (("gtk-update-icon-cache") "true"))
+ #t)))
#:configure-flags
;; Otherwise, the RUNPATH will lack the final 'epiphany' path component.
(list (string-append "-Dc_link_args=-Wl,-rpath="
@@ -4496,7 +4504,6 @@ a secret password store, an adblocker, and a modern UI.")
(native-inputs
`(("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
("glib:bin" ,glib "bin") ; for glib-mkenums
- ("gtk+:bin" ,gtk+ "bin") ; for gtk-update-icon-cache
("intltool" ,intltool)
("itstool" ,itstool)
("pkg-config" ,pkg-config)