summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-01-03 14:07:33 -0500
committerLeo Famulari <leo@famulari.name>2016-01-15 16:45:24 -0500
commitb97c1bfd5675a4465f006d4c36f8953b005e40b8 (patch)
treec6b04f430425551b82a6642afabf3a26c6454e2d /gnu
parent226d333103dd648b0efa86345da751abb763b6a4 (diff)
downloadguix-patches-b97c1bfd5675a4465f006d4c36f8953b005e40b8.tar
guix-patches-b97c1bfd5675a4465f006d4c36f8953b005e40b8.tar.gz
gnu: python-urwid: Disable failing test test_remove_watch_file.
* gnu/packages/python.scm (python-urwid)[arguments]: Add 'disable-failing-test' phase. [source]: Use pypi-uri.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 32da247bff..c3e9f42ec1 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4361,13 +4361,22 @@ and written in Python.")
(source
(origin
(method url-fetch)
- (uri (string-append
- "https://pypi.python.org/packages/source/u/urwid/urwid-"
- version ".tar.gz"))
+ (uri (pypi-uri "urwid" version))
(sha256
(base32
"18mb0yy94sjc434rd61m2sfnw27sa0nyrszpj5a9r9zh7fnlzw19"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; Disable failing test. Bug filed upstream:
+ ;; https://github.com/wardi/urwid/issues/164
+ ;; TODO: check again for python-urwid > 1.3.0 or python > 3.4.3.
+ (add-after 'unpack 'disable-failing-test
+ (lambda _
+ (substitute* "urwid/tests/test_event_loops.py"
+ (("test_remove_watch_file")
+ "disable_remove_watch_file")))))))
(native-inputs `(("python-setuptools" ,python-setuptools)))
(home-page "http://urwid.org")
(synopsis "Console user interface library for Python")