summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-08-31 19:47:31 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-08-31 23:13:46 -0400
commitb4c2d6d60fe0a929c35439768080b7e15258a7cd (patch)
tree0fdf84951fa2e91320a880657ec5d8cf72209352 /gnu
parent1a7fb20e8c50b56083a3196b37ef570ab8b7cc6e (diff)
downloadguix-patches-b4c2d6d60fe0a929c35439768080b7e15258a7cd.tar
guix-patches-b4c2d6d60fe0a929c35439768080b7e15258a7cd.tar.gz
gnu: Add python-paho-mqtt.
* gnu/packages/messaging.scm (python-paho-mqtt): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/messaging.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index c5dd20116e..841e22e5b9 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -35,6 +35,7 @@
;;; Copyright © 2022 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
;;; Copyright © 2022 Jack Hill <jackhill@jackhill.us>
+;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2900,6 +2901,36 @@ as phones, embedded computers or microcontrollers.")
;; Dual licensed.
(license (list license:epl1.0 license:edl1.0))))
+(define-public python-paho-mqtt
+ (package
+ (name "python-paho-mqtt")
+ (version "1.6.1")
+ (source (origin
+ (method git-fetch) ;for tests
+ (uri (git-reference
+ (url "https://github.com/eclipse/paho.mqtt.python")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0679iafabd3kvk4fj4lvcl14zg82yq5pz5rji4z659lm2g2zlwgn"))))
+ (build-system python-build-system)
+ (arguments (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv")))))))
+ (native-inputs (list python-pytest))
+ (home-page "https://www.eclipse.org/paho/")
+ (synopsis "Python implementation of an MQTT client class")
+ (description "MQTT and MQTT-SN are lightweight publish/subscribe messaging
+transports for TCP/IP and connection-less protocols (such as UDP). The
+Eclipse Paho project provides client side implementations of MQTT and MQTT-SN
+in a variety of programming languages. This package is for the Python
+implementation of an MQTT version client class.")
+ (license (list license:epl2.0 license:edl1.0)))) ;dual licensed
+
(define-public movim-desktop
(let ((commit "83d583b83629dbd2ec448da9a1ffd81f6c1fb295")
(revision "3"))