summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2014-12-18 21:23:52 +0100
committerFederico Beffa <beffa@fbengineering.ch>2015-01-12 18:00:08 +0100
commitb47e1b20bd83191919fd452a6fc8b9a94690c3b7 (patch)
tree02ef98b8fc403d42af6731af2f1c26d484e61688 /gnu
parent61771a79abb4a354d48469be9744f9537caefc96 (diff)
downloadguix-patches-b47e1b20bd83191919fd452a6fc8b9a94690c3b7.tar
guix-patches-b47e1b20bd83191919fd452a6fc8b9a94690c3b7.tar.gz
gnu: dconf: Add dconf.
* gnu/packages/gnome.scm (dconf): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index a2ef712220..ee143f3627 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1392,3 +1392,56 @@ editors, IDEs, etc.")
(propagated-inputs
`(("gtk+" ,gtk+-2) ; required by libvte.pc
("ncurses" ,ncurses))))) ; required by libvte.la
+
+(define-public dconf
+ (package
+ (name "dconf")
+ (version "0.22.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32 "13jb49504bir814v8n8vjip5sazwfwsrnniw87cpg7phqfq7q9qa"))))
+ (build-system glib-or-gtk-build-system)
+ (inputs
+ `(("gtk+" ,gtk+)
+ ("glib" ,glib)
+ ("dbus" ,dbus)
+ ("libxml2" ,libxml2)))
+ (native-inputs
+ `(("libxslt" ,libxslt)
+ ("docbook-xml" ,docbook-xml-4.2)
+ ("docbook-xsl" ,docbook-xsl)
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (arguments
+ `(#:tests? #f ; To contact dbus it needs to load /var/lib/dbus/machine-id
+ ; or /etc/machine-id.
+ #:configure-flags
+ ;; Set the correct RUNPATH in binaries.
+ (list (string-append "LDFLAGS=-Wl,-rpath="
+ (assoc-ref %outputs "out") "/lib")
+ "--disable-gtk-doc-html") ; FIXME: requires gtk-doc
+ #:phases
+ (alist-cons-before
+ 'configure 'fix-docbook
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "docs/Makefile.in"
+ (("http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl")
+ (string-append (assoc-ref inputs "docbook-xsl")
+ "/xml/xsl/docbook-xsl-"
+ ,(package-version docbook-xsl)
+ "/manpages/docbook.xsl")))
+ (setenv "XML_CATALOG_FILES"
+ (string-append (assoc-ref inputs "docbook-xml")
+ "/xml/dtd/docbook/catalog.xml")))
+ %standard-phases)))
+ (home-page "https://developer.gnome.org/dconf")
+ (synopsis "Low-level GNOME configuration system")
+ (description "Dconf is a low-level configuration system. Its main purpose
+is to provide a backend to GSettings on platforms that don't already have
+configuration storage systems.")
+ (license license:lgpl2.1)))