summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authordan <i@dan.games>2022-11-07 04:46:35 +0800
committer宋文武 <iyzsong@member.fsf.org>2022-11-07 16:10:09 +0800
commitb2a5dbcef89c95251fa4bebf94c165df52ae49ba (patch)
tree10a1770a84a15af87cd4356281b2105dfc384bae /gnu
parentfbca2ed4b716ac14559fe4fb2e148a39d669d7e4 (diff)
downloadguix-patches-b2a5dbcef89c95251fa4bebf94c165df52ae49ba.tar
guix-patches-b2a5dbcef89c95251fa4bebf94c165df52ae49ba.tar.gz
gnu: fcitx5-gtk: Update to 5.0.19.
* gnu/packages/fcitx5.scm (fcitx5-gtk): Update to 5.0.19. * gnu/packages/fcitx5.scm (fcitx5-gtk4) [phases]: Make gtk4/gtk4inputwindow.cpp properly find fcitxtheme.h. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/fcitx5.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/fcitx5.scm b/gnu/packages/fcitx5.scm
index 634c0395c4..3bc0636fb8 100644
--- a/gnu/packages/fcitx5.scm
+++ b/gnu/packages/fcitx5.scm
@@ -188,7 +188,7 @@ editors.")
(define-public fcitx5-gtk
(package
(name "fcitx5-gtk")
- (version "5.0.9")
+ (version "5.0.19")
(source
(origin
(method url-fetch)
@@ -196,7 +196,7 @@ editors.")
"/fcitx5-gtk/fcitx5-gtk-"
version ".tar.xz"))
(sha256
- (base32 "07ip4sxf3q895pp7mivv2bdwcmqjnwrmv9pg99jk73cw9bgyq00n"))))
+ (base32 "007ls91jfbs3anvcfbza1pjbbsi7q5nrw7f3nzdbyngsl3nj6k37"))))
(build-system cmake-build-system)
(arguments
(list
@@ -275,6 +275,11 @@ IM module for GTK+3 applications.
"-DENABLE_GTK3_IM_MODULE=OFF")
#:phases
#~(modify-phases %standard-phases
+ (add-before 'configure 'fix-fcitxtheme-path
+ (lambda _
+ (substitute* "gtk4/gtk4inputwindow.cpp"
+ (("<gtk3/fcitxtheme.h>")
+ "\"fcitxtheme.h\""))))
(add-before 'configure 'fix-gclient
(lambda* (#:key inputs #:allow-other-keys)
(define gclient