summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 11:20:49 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:39 +0200
commitb27c4b7a20dfb754e0c29400f7e266b2bf3d2026 (patch)
tree130692695573fe895b35e4fa733e2484f6cee595 /gnu
parentff5de6f612a549005fd34aba0b4ad8ecbecf9097 (diff)
downloadguix-patches-b27c4b7a20dfb754e0c29400f7e266b2bf3d2026.tar
guix-patches-b27c4b7a20dfb754e0c29400f7e266b2bf3d2026.tar.gz
gnu: Add texlive-mfpic4ode.
* gnu/packages/tex.scm (texlive-mfpic4ode): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 896455fad9..745c17d716 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5604,6 +5604,29 @@ to place the picture at the point where the original (La)TeX commands
appeared.")
(license license:lppl1.3+)))
+(define-public texlive-mfpic4ode
+ (package
+ (name "texlive-mfpic4ode")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/mfpic4ode/"
+ "source/latex/mfpic4ode/"
+ "tex/latex/mfpic4ode/")
+ (base32
+ "0ssmpvp1apxvinidq42pfpvjimpvd250har85n6rl7dj5fws9j8m")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/mfpic4ode")
+ (synopsis "Macros to draw direction fields and solutions of ODEs")
+ (description
+ "The package is a small set of macros for drawing direction fields, phase
+portraits and trajectories of differential equations and two dimensional
+autonomous systems. The Euler, Runge-Kutta and fourth order Runge-Kutta
+algorithms are available to solve the ODEs. The picture is translated into
+@code{mfpic} macros and MetaPost is used to create the final drawing.")
+ (license license:lppl)))
+
(define-public texlive-natbib
(package
(name "texlive-natbib")