summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-09-05 09:36:45 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-09-05 23:31:20 -0400
commitb24a0c00e40a976c908ffc2245aeb14ee87f96c0 (patch)
tree6cfb5ba42d67acabf7090d77da522fcad8bb9fce /gnu
parentcd49454b7b6ec56f2ada0f818a4cdfef95431f24 (diff)
downloadguix-patches-b24a0c00e40a976c908ffc2245aeb14ee87f96c0.tar
guix-patches-b24a0c00e40a976c908ffc2245aeb14ee87f96c0.tar.gz
gnu: Add python-testrepository.
* gnu/packages/python.scm (python-testrepository, python2-testrepository): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 72ca7e312a..57d8daf432 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1296,6 +1296,36 @@ Python tests.")
(define-public python2-fixtures
(package-with-python2 python-fixtures))
+(define-public python-testrepository
+ (package
+ (name "python-testrepository")
+ (version "0.0.20")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/t/testrepository/testrepository-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1ssqb07c277010i6gzzkbdd46gd9mrj0bi0i8vn560n2k2y4j93m"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)
+ ("python-testtools" ,python-testtools)
+ ("python-subunit" ,python-subunit)
+ ("python-fixtures" ,python-fixtures)
+ ("python-mimeparse" ,python-mimeparse)))
+ (home-page "https://launchpad.net/testrepository")
+ (synopsis "Database for Python test results")
+ (description "Testrepository provides a database of test results which can
+be used as part of a developer's workflow to check things such as what tests
+have failed since the last commit or what tests are currently failing.")
+ (license (list bsd-3 asl2.0)))) ; at user's option
+
+(define-public python2-testrepository
+ (package-with-python2 python-testrepository))
+
(define-public behave
(package
(name "behave")