summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-11-24 13:37:34 -0500
committerDavid Thompson <dthompson2@worcester.edu>2015-11-25 11:44:11 -0500
commitb0b23e52a3a6659fc7a4e2246e90859d7e0e8b55 (patch)
tree5ca0047894b05c523ad1520dc44c1f082e4031aa /gnu
parent33ae9107d8b60c8c418bc0b7c6ee17af99c85e2f (diff)
downloadguix-patches-b0b23e52a3a6659fc7a4e2246e90859d7e0e8b55.tar
guix-patches-b0b23e52a3a6659fc7a4e2246e90859d7e0e8b55.tar.gz
gnu: Add jasper.
* gnu/packages/image.scm (jasper): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/image.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 37221b0c27..8a4a42a295 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -703,3 +703,24 @@ applications with support for many types of images. DevIL can load, save,
convert, manipulate, filter and display a wide variety of image formats.")
(home-page "http://openil.sourceforge.net")
(license license:lgpl2.1+)))
+
+(define-public jasper
+ (package
+ (name "jasper")
+ (version "1.900.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.ece.uvic.ca/~frodo/jasper"
+ "/software/jasper-" version ".zip"))
+ (sha256
+ (base32
+ "154l7zk7yh3v8l2l6zm5s2alvd2fzkp6c9i18iajfbna5af5m43b"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("unzip" ,unzip)))
+ (synopsis "JPEG-2000 library")
+ (description "The JasPer Project is an initiative to provide a reference
+implementation of the codec specified in the JPEG-2000 Part-1 standard (i.e.,
+ISO/IEC 15444-1).")
+ (home-page "https://www.ece.uvic.ca/~frodo/jasper/")
+ (license (license:x11-style "file://LICENSE"))))