summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-01-15 18:46:23 -0500
committerMark H Weaver <mhw@netris.org>2015-01-15 20:27:57 -0500
commitb01a0ba86e93012044f42c41ba5cbc7d7936c356 (patch)
tree1fb1705c16d1a44181b9ca5dac45e59d86bf8734 /gnu
parent9fdd80e8f28a7d48615fa4d5652e81ea5f679485 (diff)
downloadguix-patches-b01a0ba86e93012044f42c41ba5cbc7d7936c356.tar
guix-patches-b01a0ba86e93012044f42c41ba5cbc7d7936c356.tar.gz
gnu: gd: Update to 2.1.1.
* gnu/packages/patches/gd-mips64-deplibs-fix.patch: Remove file. * gnu-system.am (dist_patch_DATA): Remove it. * gnu/packages/gd.scm (gd): Update to 2.1.1. Update source URI. Remove patch. Remove 'chdir' phase. Add pkg-config to native-inputs.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gd.scm22
-rw-r--r--gnu/packages/patches/gd-mips64-deplibs-fix.patch17
2 files changed, 10 insertions, 29 deletions
diff --git a/gnu/packages/gd.scm b/gnu/packages/gd.scm
index caeaeae36b..2d6ccb8d7d 100644
--- a/gnu/packages/gd.scm
+++ b/gnu/packages/gd.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -24,6 +25,7 @@
#:use-module (gnu packages image)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages pkg-config)
#:use-module ((guix licenses) #:select (bsd-style)))
(define-public gd
@@ -31,25 +33,21 @@
(name "gd")
;; Note: With libgd.org now pointing to bitbucket.org, genuine old
- ;; tarballs are no longer available. Notably, versions 2.0.34 and .35 are
+ ;; tarballs are no longer available. Notably, versions 2.0.x are
;; missing.
- (version "2.0.33")
+ (version "2.1.1")
(source (origin
(method url-fetch)
- (uri "https://bitbucket.org/libgd/gd-libgd/get/GD_2_0_33.tar.gz")
+ (uri (string-append
+ "https://bitbucket.org/libgd/gd-libgd/downloads/"
+ "libgd-" version ".tar.xz"))
(sha256
(base32
- "0yrbx8mj9pykyzm0zl1q86xlkdvkajcsf5jmg688vhw9yc5wmbbw"))
- (patches
- (list (search-patch "gd-mips64-deplibs-fix.patch")))))
+ "11djy9flzxczphigqgp7fbbblbq35gqwwhn9xfcckawlapa1xnls"))))
(build-system gnu-build-system)
- (arguments
- '(#:phases (alist-cons-after
- 'unpack 'chdir
- (lambda _
- (chdir "src"))
- %standard-phases)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
(inputs
`(("freetype" ,freetype)
("libpng" ,libpng)
diff --git a/gnu/packages/patches/gd-mips64-deplibs-fix.patch b/gnu/packages/patches/gd-mips64-deplibs-fix.patch
deleted file mode 100644
index 6231310cdb..0000000000
--- a/gnu/packages/patches/gd-mips64-deplibs-fix.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Patch configure script to choose pass_all deplibs check method for
-linux-gnu* systems on mips64. This is a temporary hack until libgd
-bootstraps their build system with a newer libtool.
-
-Patch by Mark H Weaver <mhw@netris.org>.
-
---- libgd-gd/src/configure.orig 2006-04-05 11:56:57.000000000 -0400
-+++ libgd-gd/src/configure 2013-11-02 17:56:19.123995838 -0400
-@@ -4457,7 +4457,7 @@
- # This must be Linux ELF.
- linux-gnu*)
- case $host_cpu in
-- alpha* | hppa* | i*86 | mips | mipsel | powerpc* | sparc* | ia64* | s390* | x86_64*)
-+ alpha* | hppa* | i*86 | mips | mipsel | mips64 | mips64el | powerpc* | sparc* | ia64* | s390* | x86_64*)
- lt_cv_deplibs_check_method=pass_all ;;
- *)
- # glibc up to 2.1.1 does not perform some relocations on ARM