summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-09-06 02:46:46 -0300
committerMathieu Othacehe <othacehe@gnu.org>2020-09-07 09:07:52 +0200
commitacd6cd806d6b298340121d047c9fd7f86da46c8a (patch)
tree7920608a045dca8fc0fe25058e5cb24784b03973 /gnu
parent5438adea303a52fdc08ee669ea3324c8a8765483 (diff)
downloadguix-patches-acd6cd806d6b298340121d047c9fd7f86da46c8a.tar
guix-patches-acd6cd806d6b298340121d047c9fd7f86da46c8a.tar.gz
gnu: Add python-pytest-toolbox.
* gnu/packages/python-check.scm (python-pytest-toolbox): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-check.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index b8a0d67f3d..c0de32b207 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -698,6 +698,49 @@ rounds that are calibrated to the chosen timer.")
service processes for your tests with pytest.")
(license license:expat)))
+(define-public python-pytest-toolbox
+ (package
+ (name "python-pytest-toolbox")
+ (version "0.4")
+ (source
+ (origin
+ ;; No tests in the PyPI tarball.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/samuelcolvin/pytest-toolbox")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1wqkr3g5gmqdxmhzfsxbwy8pm3cadaj6a8cxq58w9bacly4hqbh0"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ ;; Make the installed plugin discoverable by Pytest.
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-vv"))))))
+ (native-inputs
+ `(("python-coverage" ,python-coverage)
+ ("python-docutils" ,python-docutils)
+ ("python-flake8" ,python-flake8)
+ ("python-isort" ,python-isort)
+ ("python-pydantic" ,python-pydantic)
+ ("python-pyflakes" ,python-pyflakes)
+ ("python-pygments" ,python-pygments)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-isort" ,python-pytest-isort)
+ ("python-pytest-mock" ,python-pytest-mock)
+ ("python-pytest-sugar" ,python-pytest-sugar)))
+ (home-page "https://github.com/samuelcolvin/pytest-toolbox")
+ (synopsis "Numerous useful plugins for Pytest")
+ (description
+ "Pytest Toolbox contains many useful plugins for Pytest. Among them are
+new fixtures, new methods and new comparison objects.")
+ (license license:expat)))
+
(define-public python-pytest-aiohttp
(package
(name "python-pytest-aiohttp")