summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-06-22 09:06:53 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-06-22 09:07:51 +0200
commitacba72b9146edf4b12aa3625ff2cdcd4cf513b6d (patch)
tree0f18f368f41da5d2b15a916e8c49aeb312e90cb5 /gnu
parent0e0b5977b72c5bcd7926d6dcf1c0e8c8bfa7e1c2 (diff)
downloadguix-patches-acba72b9146edf4b12aa3625ff2cdcd4cf513b6d.tar
guix-patches-acba72b9146edf4b12aa3625ff2cdcd4cf513b6d.tar.gz
gnu: express: Update to 1.5.3.
* gnu/packages/bioinformatics.scm (express): Update to 1.5.3. [source]: Fetch from Github. [arguments]: Add phase "remove-update-check".
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm20
1 files changed, 13 insertions, 7 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 95f8b16db3..a2d83e3acc 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3050,16 +3050,16 @@ dynamic programming or a variety of heuristics.")
(define-public express
(package
(name "express")
- (version "1.5.1")
+ (version "1.5.3")
(source (origin
- (method url-fetch)
- (uri
- (string-append
- "http://bio.math.berkeley.edu/eXpress/downloads/express-"
- version "/express-" version "-src.tgz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/adarob/eXpress.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "03rczxd0gjp2l1jxcmjfmf5j94j77zqyxa6x063zsc585nj40n0c"))))
+ "18nb22n7x820fzjngf4qgyb3mspqkw7xyk7v7s5ps6wfrd8qwscb"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ;no "check" target
@@ -3076,6 +3076,12 @@ dynamic programming or a variety of heuristics.")
(("\\$\\{CMAKE_CURRENT_SOURCE_DIR\\}/\\.\\./bamtools/lib")
(string-append (assoc-ref inputs "bamtools") "/lib"))
(("libprotobuf.a") "libprotobuf.so"))
+ #t))
+ (add-after 'unpack 'remove-update-check
+ (lambda _
+ (substitute* "src/main.cpp"
+ (("#include \"update_check.h\"") "")
+ (("check_version\\(PACKAGE_VERSION\\);") ""))
#t)))))
(inputs
`(("boost" ,boost)