summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-04-23 10:10:59 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-04-23 17:21:19 +0300
commitabee44d2c31b3be79be68806d5721bf3edfa77e2 (patch)
tree4a8768227333a7043e1870d8214c7dfd6fd60982 /gnu
parent7af92387cf537bcf0d597a0d875e411da4218834 (diff)
downloadguix-patches-abee44d2c31b3be79be68806d5721bf3edfa77e2.tar
guix-patches-abee44d2c31b3be79be68806d5721bf3edfa77e2.tar.gz
gnu: cobol: Add missing inputs.
Reported by Simon Sobisch <simonsobisch@gnu.org>. * gnu/packages/cobol.scm (gnucobol)[inputs]: Add json-c, libxml2. Move newcob ... [native-inputs]: ... to here. [arguments]: Add configure-flag to set json-c cflags.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cobol.scm23
1 files changed, 15 insertions, 8 deletions
diff --git a/gnu/packages/cobol.scm b/gnu/packages/cobol.scm
index 27fcc260dc..60af9f6a53 100644
--- a/gnu/packages/cobol.scm
+++ b/gnu/packages/cobol.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017, 2018, 2021 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25,7 +25,9 @@
#:use-module (gnu packages dbm)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages ncurses)
- #:use-module (gnu packages perl))
+ #:use-module (gnu packages perl)
+ #:use-module (gnu packages web)
+ #:use-module (gnu packages xml))
(define-public gnucobol
(package
@@ -43,7 +45,10 @@
(arguments
'(#:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath="
(assoc-ref %outputs "out")
- "/lib"))
+ "/lib")
+ (string-append "JSON_C_CFLAGS=-I"
+ (assoc-ref %build-inputs "json-c")
+ "/include/json-c"))
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'place-cobol85-test-suite
@@ -55,17 +60,19 @@
(lambda _ (setenv "TERM" "xterm-256color"))))
#:test-target "checkall"))
(native-inputs
- `(("perl" ,perl)))
- (inputs
- `(("bdb" ,bdb)
- ("gmp" ,gmp)
- ("ncurses" ,ncurses)
+ `(("perl" ,perl)
("newcob" ,(origin
(method url-fetch)
(uri "https://www.itl.nist.gov/div897/ctg/suites/newcob.val.Z")
(sha256
(base32
"1yb1plmv4firfnbb119r2vh1hay221w1ya34nyz0qwsxppfr56hy"))))))
+ (inputs
+ `(("bdb" ,bdb)
+ ("gmp" ,gmp)
+ ("json-c" ,json-c)
+ ("libxml2" ,libxml2)
+ ("ncurses" ,ncurses)))
(build-system gnu-build-system)
(home-page "https://www.gnu.org/software/gnucobol/")
(synopsis "A modern COBOL compiler")