summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-11-06 22:32:32 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-11-06 22:45:47 +0100
commitab6fb3022debcb523cce5ae762ea58ca01f4c687 (patch)
treed47243c6ea3833ec05b009e96ab248f17904cf23 /gnu
parentb53355f08d15e919023c3fb77d27ba9e3d889880 (diff)
downloadguix-patches-ab6fb3022debcb523cce5ae762ea58ca01f4c687.tar
guix-patches-ab6fb3022debcb523cce5ae762ea58ca01f4c687.tar.gz
gnu: emacs-deadgrep: Improve package style.
* gnu/packages/emacs-xyz.scm (emacs-deadgrep)[arguments]: Use G-expressions. <#:phases>: Use SEARCH-INPUT-FILE instead of ASSOC-REF.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm27
1 files changed, 13 insertions, 14 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ab5f08a5db..5c6abdbcd2 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -23875,22 +23875,21 @@ accept and reject GitHub pull requests.")
(base32
"0bwf8gsqw7hsmacqd34piwgv066ijfclmxaigkvhvpac0lpsmi79"))))
(build-system emacs-build-system)
- (inputs (list ripgrep))
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((ripgrep (search-input-file inputs "/bin/rg")))
+ ;; Specify the absolute file name of rg so that everything
+ ;; works out-of-the-box.
+ (emacs-substitute-variables "deadgrep.el"
+ ("deadgrep-executable" ripgrep))))))))
+ (inputs
+ (list ripgrep))
(propagated-inputs
(list emacs-dash emacs-s emacs-spinner))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'configure
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((ripgrep (assoc-ref inputs "ripgrep")))
- ;; .el is read-only in git.
- (make-file-writable "deadgrep.el")
- ;; Specify the absolute file names of rg so that everything
- ;; works out-of-the-box.
- (emacs-substitute-variables "deadgrep.el"
- ("deadgrep-executable"
- (string-append ripgrep "/bin/rg")))))))))
(home-page "https://github.com/Wilfred/deadgrep")
(synopsis "Frontend for @code{ripgrep}")
(description "This package provides an Emacs interface for performing