summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-07-28 21:23:34 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-07-28 21:25:57 +0200
commita81a64492fbf0ab25b87205850c9f0cd13e6b656 (patch)
tree05f6ae0a8b26afd8ad2303a7fa984135a0fbcb7c /gnu
parentccd0a009dc865ec1ee490fdf687597f3188d9cc5 (diff)
downloadguix-patches-a81a64492fbf0ab25b87205850c9f0cd13e6b656.tar
guix-patches-a81a64492fbf0ab25b87205850c9f0cd13e6b656.tar.gz
gnu: anki: Don't phone home for updates.
* gnu/packages/education.scm (anki)[arguments]: Add a ‘disable-update-check’ phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/education.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 99e7b669b4..a4081cc374 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -758,6 +758,13 @@ adjust the level of difficulty.")
(ice-9 match))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'disable-update-check
+ ;; Don't ‘phone home’ unasked to check for updates.
+ (lambda _
+ (substitute* "aqt/update.py"
+ (("requests\\.post")
+ "throw.an.exception.instead"))
+ #t))
(delete 'configure) ;no configure script
(add-after 'install 'wrap
(lambda* (#:key inputs outputs #:allow-other-keys)