summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-07-04 23:53:00 +0200
committerJulien Lepiller <julien@lepiller.eu>2020-07-05 14:12:53 +0200
commita5f8d4e0b383edeb34861f0c52c5dcd702a5e078 (patch)
tree1c921ef3c108a1bb66b65811e94394795a9a2287 /gnu
parentee1dc9b3d19364e17b15a158194cddfff91778c8 (diff)
downloadguix-patches-a5f8d4e0b383edeb34861f0c52c5dcd702a5e078.tar
guix-patches-a5f8d4e0b383edeb34861f0c52c5dcd702a5e078.tar.gz
gnu: Add java-jetbrains-annotations.
* gnu/packages/java.scm (java-jetbrains-annotations): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 113108eb58..170936a0ff 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -12050,3 +12050,28 @@ Isolation and Durability) properties.")
for the JVM. It supports colors, autocompletion, subcommands, and more. Written
in Java, usable from Groovy, Kotlin, Scala, etc.")
(license license:asl2.0)))
+
+(define-public java-jetbrains-annotations
+ (package
+ (name "java-jetbrains-annotations")
+ (version "19.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JetBrains/java-annotations")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0z6i1xs60cd5ffz23c49sq68wn5mphhs3xpar1n93ppama2ng80v"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:jar-name "jetbrains-annotations.jar"
+ #:source-dir "common/src/main/java:java8/src/main/java"
+ #:tests? #f)); no tests
+ (home-page "https://github.com/JetBrains/java-annotations")
+ (synopsis "Annotations for Java and other JVM languages")
+ (description "This package contains a set of Java annotations which can be
+used in JVM-based languages. They serve as an additional documentation and
+can be interpreted by IDEs and static analysis tools to improve code analysis.")
+ (license license:expat)))