summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-06-14 10:37:35 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-06-14 14:45:19 +0300
commita5daa8c0ab400bffc53f245069a62c9503addf63 (patch)
tree2ee0d5d147670d5a658cc8d588853d9f7cfc7bae /gnu
parentadb3d8797d0521f3e08a9ecaff33f79ee4cead01 (diff)
downloadguix-patches-a5daa8c0ab400bffc53f245069a62c9503addf63.tar
guix-patches-a5daa8c0ab400bffc53f245069a62c9503addf63.tar.gz
gnu: Add julia-json3.
* gnu/packages/julia-xyz.scm (julia-json3): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/julia-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 4ddebff80a..bd24f814a5 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1552,6 +1552,29 @@ extensions to the iterator interface.")
and printing JSON documents.")
(license license:expat)))
+(define-public julia-json3
+ (package
+ (name "julia-json3")
+ (version "1.8.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/quinnj/JSON3.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1mc3byqm6ygg4mjpdrx6grkr4gn06p25nr7050jgq1k2cf06iqba"))))
+ (build-system julia-build-system)
+ (propagated-inputs
+ `(("julia-parsers" ,julia-parsers)
+ ("julia-structtypes" ,julia-structtypes)))
+ (home-page "https://github.com/quinnj/JSON3.jl")
+ (synopsis "JSON package for Julia")
+ (description "This package provides another JSON package for Julia, with a
+focus on speed and slick struct mapping.")
+ (license license:expat)))
+
(define-public julia-lazyarrays
(package
(name "julia-lazyarrays")