summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-07-24 09:01:43 -0300
committerMarius Bakke <marius@gnu.org>2020-07-25 18:47:57 +0200
commita5d27dbe8e44f7d9054f88ee49963a290ee5be24 (patch)
tree231ccf32d882dcafa66a207b94fbf546d09a727c /gnu
parentb8bf0f8c2ce8931298bb810e747836acfb06011c (diff)
downloadguix-patches-a5d27dbe8e44f7d9054f88ee49963a290ee5be24.tar
guix-patches-a5d27dbe8e44f7d9054f88ee49963a290ee5be24.tar.gz
gnu: Add python-pytest-env.
* gnu/packages/python-check.scm (python-pytest-env): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-check.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index f71eef0c92..e96ce9e666 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -673,6 +673,26 @@ service processes for your tests with pytest.")
"This pytest plugin provides fixtures to simplify Flask app testing.")
(license license:expat)))
+(define-public python-pytest-env
+ (package
+ (name "python-pytest-env")
+ (version "0.6.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-env" version))
+ (sha256
+ (base32 "1hl0ln0cicdid4qjk7mv90lw9xkb0v71dlj7q7rn89vzxxm9b53y"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/MobileDynasty/pytest-env")
+ (synopsis "Pytest plugin that allows you to add environment variables")
+ (description
+ "This is a @code{py.test} plugin that enables you to set environment
+variables in the @file{pytest.ini} file.")
+ (license license:expat)))
+
(define-public python-codacy-coverage
(package
(name "python-codacy-coverage")