summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-06 12:17:26 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:33 +0200
commita4d0c9d134f3baff1eb66f0e2b860af74a72864d (patch)
tree5f619f5ef0aadaf85ae5b32bd3acd856afc7cc08 /gnu
parent69b1df59e3379935538cf0737b038fa31088c71c (diff)
downloadguix-patches-a4d0c9d134f3baff1eb66f0e2b860af74a72864d.tar
guix-patches-a4d0c9d134f3baff1eb66f0e2b860af74a72864d.tar.gz
gnu: Add texlive-luabidi.
* gnu/packages/tex.scm (texlive-luabidi): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 32a2f624b1..7b4fe634a1 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4124,6 +4124,28 @@ releases. The bundle consists of a Lua script to run the tasks and a
@code{.tex} file which provides the testing environment.")
(license license:lppl1.3c+))))
+(define-public texlive-luabidi
+ (package
+ (name "texlive-luabidi")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/lualatex/luabidi/"
+ "tex/lualatex/luabidi/")
+ (base32
+ "1dwdiwsdfhgwpx8r2271i5kqphcpkh69y3rx1wxfr9hl17lzw2cp")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-bigfoot ;for "perpage.sty"
+ texlive-etoolbox))
+ (home-page "https://ctan.org/pkg/luabidi")
+ (synopsis "Bidi functions for LuaTeX")
+ (description
+ "The package attempts to emulate the XeTeX @code{bidi} package, in the
+context of LuaTeX.")
+ (license (list license:lppl1.3c license:expat))))
+
(define-public texlive-lualatex-math
(package
(name "texlive-lualatex-math")