summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorZhu Zihao <all_but_last@163.com>2022-08-06 23:10:56 +0800
committerLudovic Courtès <ludo@gnu.org>2022-09-01 00:57:10 +0200
commita4cc6b59096e38620efcf7449797566fa64f8b35 (patch)
treefee50ddcb26112bd0b0cdda3763305b95ad08611 /gnu
parent0d8739bd6d9f654e366c4b53f58c5914a6fd8391 (diff)
downloadguix-patches-a4cc6b59096e38620efcf7449797566fa64f8b35.tar
guix-patches-a4cc6b59096e38620efcf7449797566fa64f8b35.tar.gz
gnu: tdlib: Use G-expressions.
* gnu/packages/messaging.scm (tdlib)[arguments]: Use G-expressions. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/messaging.scm27
1 files changed, 14 insertions, 13 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index a2695370e3..ace671c271 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2665,19 +2665,20 @@ replacement.")
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(arguments
- `(#:configure-flags
- (list "-DCMAKE_BUILD_TYPE=Release"
- "-DTD_ENABLE_LTO=OFF") ; FIXME: Get LTO to work.
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'remove-failing-tests
- (lambda _
- (substitute* "test/CMakeLists.txt"
- ;; The test cases are compiled into a distinct binary
- ;; which uses mtproto.cpp to attempt to connect to
- ;; a remote server. Removing this file from the sources
- ;; list disables those specific test cases.
- (("\\$\\{CMAKE_CURRENT_SOURCE_DIR\\}/mtproto.cpp") "")))))))
+ (list
+ #:configure-flags
+ #~(list "-DCMAKE_BUILD_TYPE=Release"
+ "-DTD_ENABLE_LTO=OFF") ; FIXME: Get LTO to work.
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-failing-tests
+ (lambda _
+ (substitute* "test/CMakeLists.txt"
+ ;; The test cases are compiled into a distinct binary
+ ;; which uses mtproto.cpp to attempt to connect to
+ ;; a remote server. Removing this file from the sources
+ ;; list disables those specific test cases.
+ (("\\$\\{CMAKE_CURRENT_SOURCE_DIR\\}/mtproto.cpp") "")))))))
(native-inputs
(list gperf openssl zlib php doxygen))
(synopsis "Cross-platform library for building Telegram clients")