summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-04-20 09:49:32 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-04-26 10:26:47 +0200
commita0e98da14f318f02b008b71d6bf236171dff67e3 (patch)
tree45f063bcc2deec7ff040dc9d881273633ddbe4c3 /gnu
parent7f06ab7fc0429fa736fd77cb1ebe5a69f9909f65 (diff)
downloadguix-patches-a0e98da14f318f02b008b71d6bf236171dff67e3.tar
guix-patches-a0e98da14f318f02b008b71d6bf236171dff67e3.tar.gz
gnu: Add python-jupyter-client-bootstrap.
* gnu/packages/python-xyz.scm (python-jupyter-client-bootstrap): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ea67dfc78f..fcd8b2d76f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7469,6 +7469,20 @@ for working with kernels, and the @code{jupyter kernelspec} entrypoint for
installing @code{kernelspec}s for use with Jupyter frontends.")
(license license:bsd-3)))
+;; Bootstrap variant of jupyter-client, which breaks the loop between ipykernel
+;; and jupyter-client by removing the former from its native-inputs and
+;; disabling tests.
+(define-public python-jupyter-client-bootstrap
+ (let ((base python-jupyter-client))
+ (hidden-package
+ (package
+ (inherit base)
+ (name "python-jupyter-client-bootstrap")
+ (arguments
+ `(#:tests? #f
+ ,@(package-arguments base)))
+ (native-inputs `())))))
+
(define-public python2-jupyter-client
(package-with-python2 python-jupyter-client))