summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorKonrad Hinsen <konrad.hinsen@fastmail.net>2017-12-20 17:19:14 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2017-12-23 22:35:53 +0100
commita08d5a07a921af93487c1b52cd0c1fb8fbe27b51 (patch)
tree9f7e815b1d0125849cb0ef233d7f02f822a47c51 /gnu
parente144cbcf850adca4cac8a4548632add1dc738219 (diff)
downloadguix-patches-a08d5a07a921af93487c1b52cd0c1fb8fbe27b51.tar
guix-patches-a08d5a07a921af93487c1b52cd0c1fb8fbe27b51.tar.gz
gnu: Add python2-numpy-1.8.
* gnu/packages/python.scm (python2-numpy-1.8): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 5dc7b1d847..a3e1a885f9 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2694,6 +2694,49 @@ capabilities.")
(define-public python2-numpy-next
(package-with-python2 python-numpy-next))
+;; NOTE: NumPy 1.8 is packaged only for Python 2 because it is of
+;; interest only for legacy code going back to NumPy's predecessor
+;; Numeric.
+(define-public python2-numpy-1.8
+ (package (inherit python2-numpy)
+ (version "1.8.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/numpy/numpy/archive/v" version ".tar.gz"))
+ (file-name (string-append "python2-numpy-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0sc20gz1b17xnyrkp5frca3ql5qfalpv916hfg2kqxpwr6jg0f1g"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments python2-numpy)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (replace 'configure-blas-lapack
+ (lambda* (#:key inputs #:allow-other-keys)
+ (call-with-output-file "site.cfg"
+ (lambda (port)
+ (format port
+ "[openblas]
+libraries = openblas,lapack
+library_dirs = ~a/lib:~a/lib
+include_dirs = ~a/include:~a/include
+"
+ (assoc-ref inputs "openblas")
+ (assoc-ref inputs "lapack")
+ (assoc-ref inputs "openblas")
+ (assoc-ref inputs "lapack"))))
+ #t))))))
+ (description "NumPy is the fundamental package for scientific computing
+with Python. It contains among other things: a powerful N-dimensional array
+object, sophisticated (broadcasting) functions, tools for integrating C/C++
+and Fortran code, useful linear algebra, Fourier transform, and random number
+capabilities. Version 1.8 is the last one to contain the numpy.oldnumeric API
+that includes the compatibility layer numpy.oldnumeric with NumPy's predecessor
+Numeric.")
+ (license license:bsd-3)))
+
(define-public python-munch
(package
(name "python-munch")