summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-07-06 09:45:38 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-07-06 09:46:59 +0200
commita07a1b0eab5f739a9beb4284bec4ed5701405663 (patch)
tree3614304ffb4e12063e9e8e639096d6b35de5b0ed /gnu
parent3d80e618ddbd40342ed7e69f898801e8e3a64eaa (diff)
downloadguix-patches-a07a1b0eab5f739a9beb4284bec4ed5701405663.tar
guix-patches-a07a1b0eab5f739a9beb4284bec4ed5701405663.tar.gz
gnu: emacs-lsp-mode: Update to 7.0.
* gnu/packages/emacs-xyz.scm (emacs-lsp-mode): Update to 7.0. [description]: Slightly improve typography and wording.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm33
1 files changed, 17 insertions, 16 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b1e9c59585..2fdda96b45 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19232,30 +19232,31 @@ the standard @code{Dockerfile} file format.")
(define-public emacs-lsp-mode
(package
(name "emacs-lsp-mode")
- (version "6.3.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/emacs-lsp/lsp-mode.git")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "125rpmhlyd6wmq7p71j54x3rzmk07vn1hdcvvdjjip5481raxcwx"))))
+ (version "7.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacs-lsp/lsp-mode.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1kw32dcm73i0kg1fncp6vwgar3dwva7dh3gkg5cr45gavn6rq34i"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-dash" ,emacs-dash)
("emacs-f" ,emacs-f)
("emacs-ht" ,emacs-ht)
+ ("emacs-hydra" ,emacs-hydra)
("emacs-markdown-mode" ,emacs-markdown-mode)
- ("emacs-spinner" ,emacs-spinner)
- ("emacs-hydra" ,emacs-hydra)))
+ ("emacs-spinner" ,emacs-spinner)))
(home-page "https://emacs-lsp.github.io/lsp-mode/")
(synopsis "Emacs client and library for the Language Server Protocol")
- (description "@code{LSP-mode} is a client and library implementation for
-the Language Server Protocol. This mode aims to provide an IDE-like
-experience by providing optional integration with other popular Emacs packages
-like @code{company}, @code{flycheck}, and @code{projectile}.")
+ (description
+ "LSP mode is a client and library implementation for the Language Server
+Protocol. This mode creates an IDE-like experience by providing optional
+integration with other popular Emacs packages like Company, Flycheck, and
+Projectile.")
(license license:gpl3+)))
(define-public emacs-pfuture