summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAdam Kandur <rndd@tuta.io>2020-08-02 09:24:59 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2020-08-02 09:26:48 +0200
commita05edef2ac692be8bf3033fe008b7c1b29f83123 (patch)
tree93520f1e223d8c4b2188d4ecc2d89d050f3612cf /gnu
parentc203be27cfdc9ebf8c1a201a1f24626ec57578a3 (diff)
downloadguix-patches-a05edef2ac692be8bf3033fe008b7c1b29f83123.tar
guix-patches-a05edef2ac692be8bf3033fe008b7c1b29f83123.tar.gz
gnu: Add cl-qbase64.
* gnu/packages/lisp-xyz.scm (sbcl-qbase64, cl-qbase64, ecl-qbase64): New variables. Co-authored-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 5ec99b0c93..767f50c104 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -13364,3 +13364,34 @@ Inflector module.")
(define-public ecl-cl-inflector
(sbcl-package->ecl-package sbcl-cl-inflector))
+
+(define-public sbcl-qbase64
+ (package
+ (name "sbcl-qbase64")
+ (version "0.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/chaitanyagupta/qbase64")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1dir0s70ca3hagxv9x15zq4p4ajgl7jrcgqsza2n2y7iqbxh0dwi"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("metabang-bind" ,sbcl-metabang-bind)
+ ("trivial-gray-streams" ,sbcl-trivial-gray-streams)))
+ (native-inputs
+ `(("fiveam" ,sbcl-fiveam)))
+ (home-page "https://github.com/chaitanyagupta/qbase64")
+ (synopsis "Base64 encoder and decoder for Common Lisp")
+ (description "@code{qbase64} provides a fast and flexible base64 encoder
+and decoder for Common Lisp.")
+ (license license:bsd-3)))
+
+(define-public cl-qbase64
+ (sbcl-package->cl-source-package sbcl-qbase64))
+
+(define-public ecl-qbase64
+ (sbcl-package->ecl-package sbcl-qbase64))