summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-09-05 18:23:22 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-09-05 23:31:20 -0400
commit9dd6078d3b7f5eff2d3ddfd9a2ca981a6634da3e (patch)
treecfeb27b8afca3e09aee28006083dcc62cb81e52e /gnu
parentfb35b7c0889f6b6f19edfc2ba26b9a97572638d3 (diff)
downloadguix-patches-9dd6078d3b7f5eff2d3ddfd9a2ca981a6634da3e.tar
guix-patches-9dd6078d3b7f5eff2d3ddfd9a2ca981a6634da3e.tar.gz
gnu: Add python-sphinx.
* gnu/packages/python.scm (python-sphinx, python2-sphinx): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f012a8d801..81b6c956a9 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1805,3 +1805,32 @@ reStructuredText.")
(define-public python2-pygments
(package-with-python2 python-pygments))
+
+(define-public python-sphinx
+ (package
+ (name "python-sphinx")
+ (version "1.2.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/S/Sphinx/Sphinx-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "011xizm3jnmf4cvs5i6kgf6c5nn046h79i8j0vd0f27yw9j3p4wl"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)
+ ("python-jinja2" ,python-jinja2)
+ ("python-docutils" ,python-docutils)
+ ("python-pygments" ,python-pygments)))
+ (home-page "http://sphinx-doc.org/")
+ (synopsis "Python documentation generator")
+ (description "Sphinx is a tool that makes it easy to create documentation
+for Python projects or other documents consisting of multiple reStructuredText
+sources.")
+ (license bsd-3)))
+
+(define-public python2-sphinx
+ (package-with-python2 python-sphinx))