summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-10-04 15:10:57 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-10-06 14:18:24 +0200
commit9ce764b689eb10ce80527db69a47d142048f811b (patch)
treea5b6bd5c7ca5e3a87f4d3018906d8c36be3b27b7 /gnu
parent37e02bf65b98c667dfe01fffa791c7010f623307 (diff)
downloadguix-patches-9ce764b689eb10ce80527db69a47d142048f811b.tar
guix-patches-9ce764b689eb10ce80527db69a47d142048f811b.tar.gz
gnu: Add ghc-rfc5051.
* gnu/packages/haskell.scm (ghc-rfc5051): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 479d8f8094..5e52dd98fd 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -6341,6 +6341,29 @@ that interconverts between various bibliography formats using a common
MODS-format XML intermediate.")
(license license:gpl2+)))
+(define-public ghc-rfc5051
+ (package
+ (name "ghc-rfc5051")
+ (version "0.1.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/rfc5051/"
+ "rfc5051-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0av4c3qvwbkbzrjrrg601ay9pds7wscqqp2lc2z78mv2lllap3g3"))))
+ (build-system haskell-build-system)
+ (home-page "http://hackage.haskell.org/package/rfc5051")
+ (synopsis "Simple unicode collation as per RFC5051")
+ (description
+ "This library implements @code{unicode-casemap}, the simple, non
+locale-sensitive unicode collation algorithm described in RFC 5051. Proper
+unicode collation can be done using @code{text-icu}, but that is a big
+dependency that depends on a large C library, and @code{rfc5051} might be
+better for some purposes.")
+ (license license:bsd-3)))
+
(define-public ghc-union-find
(package
(name "ghc-union-find")