summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-06-23 13:38:51 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-06-23 13:38:51 +0200
commit976a49bacc30ee4c77ee7e5da4ba8b4e6f32e70d (patch)
tree85495c99e5f210f5bbd98de32edd094425f11c15 /gnu
parentcde7068e8cb28b7245cfa07b8aa788039012f972 (diff)
downloadguix-patches-976a49bacc30ee4c77ee7e5da4ba8b4e6f32e70d.tar
guix-patches-976a49bacc30ee4c77ee7e5da4ba8b4e6f32e70d.tar.gz
gnu: bitcoin-unlimited: Fix build.
* gnu/packages/finance.scm (bitcoin-unlimited)[arguments]: Disable a test.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/finance.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index d4c571d3ec..b3a8e2b732 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1457,7 +1457,14 @@ following three utilities are included with the library:
(substitute* "src/Makefile.test.include"
(("test/utilprocess_tests.cpp")
""))
- #t))
+
+ ;; Some transaction validation rules have changed (see upstream
+ ;; commit f208400825d4641b9310a1fba023d56e0862e3b0), which makes
+ ;; a test fail. Disable it for now.
+ ;; TODO: Remove this when the next version is released.
+ (substitute* "src/Makefile.test.include"
+ (("test/txvalidationcache_tests.cpp")
+ ""))))
(add-before 'check 'set-home
(lambda _
(setenv "HOME" (getenv "TMPDIR")) ; tests write to $HOME