summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-06-30 15:28:14 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-06-30 21:34:29 +0200
commit9636591edfbbcbce311b1d42f315acc6d0dfa56f (patch)
treeefb79218bfb2ccd8d808d06fcf44484c0fb0daad /gnu
parent5434f6f89362a837a6712a85e5ecbc5099ab57bb (diff)
downloadguix-patches-9636591edfbbcbce311b1d42f315acc6d0dfa56f.tar
guix-patches-9636591edfbbcbce311b1d42f315acc6d0dfa56f.tar.gz
gnu: libesmtp: Build from Git sources.
* gnu/packages/mail.scm (libesmtp)[source]: Use GIT-FETCH and GIT-FILE-NAME. [native-inputs]: Add autoconf, automake, and libtool.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/mail.scm21
1 files changed, 10 insertions, 11 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index bfca298808..b739439083 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -2317,19 +2317,18 @@ format and headers.")
(version "1.0.6")
(source
(origin
- (method url-fetch)
- (uri (list (string-append "https://pkgs.fedoraproject.org/repo/pkgs/"
- "libesmtp/libesmtp-" version ".tar.bz2/"
- "bf3915e627fd8f35524a8fdfeed979c8/libesmtp-"
- version ".tar.bz2")
- ;; XXX This site is offline, so we fetch Fedora's cached copy
- ;; of the source tarball.
- (string-append "http://www.stafford.uklinux.net/libesmtp/libesmtp-"
- version ".tar.bz2")))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/libesmtp/libESMTP")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "02zbniyz7qys1jmx3ghx21kxmns1wc3hmv80gp7ag7yra9f1m9nh"))))
+ (base32 "0pylvjpdf92i0j9bl43sg37k1ksbzk1k7cgdk91kkcc0krh0r09g"))))
(build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
(propagated-inputs
`(("openssl" ,openssl)))
(home-page "http://www.stafford.uklinux.net/libesmtp/")