summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-13 12:09:15 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:46 +0200
commit9550a203618ff3cbc20381b1ac65b5ab7422661a (patch)
tree73eff7d1a5c4214d06356be2bea9860aa931f316 /gnu
parent8dba450404356e7259a7bd348dd80dfcdb9ecf91 (diff)
downloadguix-patches-9550a203618ff3cbc20381b1ac65b5ab7422661a.tar
guix-patches-9550a203618ff3cbc20381b1ac65b5ab7422661a.tar.gz
gnu: texlive-latex-upquote -> texlive-upquote.
* gnu/packages/tex.scm (texlive-upquote): New variable. (texlive-latex-upquote): Deprecate variable. * gnu/packages/cran.scm (r-prereg): * gnu/packages/maths.scm (hypre): * gnu/packages/python-xyz.scm (python-nbconvert): * gnu/packages/sphinx.scm (python-sphinx): * gnu/packages/statistics.scm (r-with-tests): Use new name.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm2
-rw-r--r--gnu/packages/maths.scm2
-rw-r--r--gnu/packages/python-xyz.scm2
-rw-r--r--gnu/packages/sphinx.scm2
-rw-r--r--gnu/packages/statistics.scm2
-rw-r--r--gnu/packages/tex.scm30
6 files changed, 21 insertions, 19 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 4e3476222d..2ef6da13f6 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -36201,7 +36201,7 @@ package online.")
texlive-graphics
texlive-latex-threeparttable
texlive-titlesec
- texlive-latex-upquote
+ texlive-upquote
texlive-listings
texlive-polyglossia
texlive-titling
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index f8cd4f385b..a462a413ac 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5814,7 +5814,7 @@ set.")
texlive-stackengine
texlive-latex-tabulary
texlive-tocloft
- texlive-latex-upquote
+ texlive-upquote
texlive-latex-varwidth
texlive-titlesec
texlive-ulem
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 100ad3647e..0165925c70 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15192,7 +15192,7 @@ time.")
texlive-ms
texlive-latex-parskip
texlive-trimspaces
- texlive-latex-upquote
+ texlive-upquote
texlive-stringenc
texlive-tcolorbox
texlive-titling
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index df701f55f0..4e912ae252 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -128,7 +128,7 @@
texlive-latex-tabulary
texlive-titlesec
texlive-tools ;multicol, longtable
- texlive-latex-upquote
+ texlive-upquote
texlive-latex-varwidth
texlive-oberdiek ;hypcap
texlive-wrapfig
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 68206ea6a1..a1f96936e4 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -399,7 +399,7 @@ as.POSIXct(if (\"\" != Sys.getenv(\"SOURCE_DATE_EPOCH\")) {\
texlive-hyperref
texlive-oberdiek
texlive-tools
- texlive-latex-upquote
+ texlive-upquote
texlive-url
texlive-latex-xkeyval))
tzdata-for-tests
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6d42ea3c13..3b5b3d2db3 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6413,26 +6413,26 @@ might say:
@end example\n")
(license license:lppl)))
-(define-public texlive-latex-upquote
+(define-public texlive-upquote
(package
- (name "texlive-latex-upquote")
+ (name "texlive-upquote")
(version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (texlive-ref "latex" "upquote"))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "0d1050i973wnxigy0xpky5l7vn4ff7ldhkjpdqsw5s653gagwixp"))))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/upquote/"
+ "source/latex/upquote/"
+ "tex/latex/upquote/")
+ (base32
+ "1manbljqx2859wq9by6bpcx4rnxvc596a05d21cw464484f8a8z2")))
+ (outputs '("out" "doc"))
(build-system texlive-build-system)
- (arguments '(#:tex-directory "latex/upquote"))
(home-page "https://www.ctan.org/pkg/upquote")
- (synopsis "Show \"realistic\" quotes in verbatim")
+ (synopsis "Show realistic quotes in verbatim")
(description
"Typewriter-style fonts are best for program listings, but Computer
-Modern Typewriter prints @code{`} and @code{'} as bent opening and closing
-single quotes. Other fonts, and most programming languages, print @code{`} as
-a grave accent and @code{'} upright; @code{'} is used both to open and to
+Modern Typewriter prints @samp{`} and @samp{'} as bent opening and closing
+single quotes. Other fonts, and most programming languages, print @samp{`} as
+a grave accent and @samp{'} upright; @samp{'} is used both to open and to
close quoted strings. The package switches the typewriter font to Computer
Modern Typewriter in OT1 encoding, and modifies the behaviour of
@code{verbatim}, @code{verbatim*}, @code{\\verb}, and @code{\\verb*} to print
@@ -6441,6 +6441,8 @@ use, so long as the package is loaded after the other fonts were. The package
does not affect @code{\\tt}, @code{\\texttt}, etc.")
(license license:lppl1.2+)))
+(define-deprecated-package texlive-latex-upquote texlive-upquote)
+
(define-public texlive-latex-anysize
(package
(name "texlive-latex-anysize")