summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBrett Gilio <brettg@posteo.net>2019-12-13 07:57:51 -0600
committerBrett Gilio <brettg@posteo.net>2019-12-13 07:58:30 -0600
commit94c7f70faa0ba0409099b423df6534718d7518cc (patch)
tree97586676534c56491725c0ed9e6299e89888fde6 /gnu
parent7711db7f4ec24015d7c2412ef1e624cbf8110ed3 (diff)
parent19ba75dc02c4ff072f96296543a00737bcf24bf9 (diff)
downloadguix-patches-94c7f70faa0ba0409099b423df6534718d7518cc.tar
guix-patches-94c7f70faa0ba0409099b423df6534718d7518cc.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu')
-rw-r--r--gnu/build/linux-boot.scm18
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/benchmark.scm6
-rw-r--r--gnu/packages/calendar.scm4
-rw-r--r--gnu/packages/cdrom.scm4
-rw-r--r--gnu/packages/coq.scm25
-rw-r--r--gnu/packages/emacs-xyz.scm41
-rw-r--r--gnu/packages/imagemagick.scm5
-rw-r--r--gnu/packages/ipfs.scm5
-rw-r--r--gnu/packages/libreoffice.scm4
-rw-r--r--gnu/packages/linux.scm23
-rw-r--r--gnu/packages/mail.scm21
-rw-r--r--gnu/packages/music.scm2
-rw-r--r--gnu/packages/patches/libnftnl-dont-check-NFTNL_FLOWTABLE_SIZE.patch47
-rw-r--r--gnu/packages/python-xyz.scm27
-rw-r--r--gnu/packages/terminals.scm10
-rw-r--r--gnu/packages/tls.scm6
-rw-r--r--gnu/packages/vpn.scm4
-rw-r--r--gnu/packages/web.scm7
19 files changed, 182 insertions, 78 deletions
diff --git a/gnu/build/linux-boot.scm b/gnu/build/linux-boot.scm
index 950a3507f2..3d40a7d05d 100644
--- a/gnu/build/linux-boot.scm
+++ b/gnu/build/linux-boot.scm
@@ -358,10 +358,10 @@ the last argument of `mknod'."
(filter-map string->number (scandir "/proc")))))
(define* (mount-root-file-system root type
- #:key volatile-root? options)
- "Mount the root file system of type TYPE at device ROOT. If VOLATILE-ROOT?
-is true, mount ROOT read-only and make it an overlay with a writable tmpfs
-using the kernel built-in overlayfs. OPTIONS indicates the options to use
+ #:key volatile-root? (flags 0) options)
+ "Mount the root file system of type TYPE at device ROOT. If VOLATILE-ROOT? is
+true, mount ROOT read-only and make it an overlay with a writable tmpfs using
+the kernel built-in overlayfs. FLAGS and OPTIONS indicates the options to use
to mount ROOT."
(if volatile-root?
@@ -384,7 +384,7 @@ to mount ROOT."
"lowerdir=/real-root,upperdir=/rw-root/upper,workdir=/rw-root/work"))
(begin
(check-file-system root type)
- (mount root "/root" type 0 options)))
+ (mount root "/root" type flags options)))
;; Make sure /root/etc/mtab is a symlink to /proc/self/mounts.
(false-if-exception
@@ -474,6 +474,13 @@ upon error."
mounts)
"ext4"))
+ (define root-fs-flags
+ (mount-flags->bit-mask (or (any (lambda (fs)
+ (and (root-mount-point? fs)
+ (file-system-flags fs)))
+ mounts)
+ '())))
+
(define root-fs-options
(any (lambda (fs)
(and (root-mount-point? fs)
@@ -533,6 +540,7 @@ upon error."
(mount-root-file-system (canonicalize-device-spec root)
root-fs-type
#:volatile-root? volatile-root?
+ #:flags root-fs-flags
#:options root-fs-options))
(mount "none" "/root" "tmpfs"))
diff --git a/gnu/local.mk b/gnu/local.mk
index b1b5045469..f4a9829239 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1012,6 +1012,7 @@ dist_patch_DATA = \
%D%/packages/patches/java-xerces-xjavac_taskdef.patch \
%D%/packages/patches/jbig2dec-ignore-testtest.patch \
%D%/packages/patches/kdbusaddons-kinit-file-name.patch \
+ %D%/packages/patches/libnftnl-dont-check-NFTNL_FLOWTABLE_SIZE.patch \
%D%/packages/patches/libvirt-create-machine-cgroup.patch \
%D%/packages/patches/libziparchive-add-includes.patch \
%D%/packages/patches/localed-xorg-keyboard.patch \
diff --git a/gnu/packages/benchmark.scm b/gnu/packages/benchmark.scm
index 8e347879dd..f9e819460e 100644
--- a/gnu/packages/benchmark.scm
+++ b/gnu/packages/benchmark.scm
@@ -43,14 +43,14 @@
(define-public fio
(package
(name "fio")
- (version "3.14")
+ (version "3.16")
(source (origin
(method url-fetch)
- (uri (string-append "http://brick.kernel.dk/snaps/"
+ (uri (string-append "https://brick.kernel.dk/snaps/"
"fio-" version ".tar.bz2"))
(sha256
(base32
- "047y53nyhnmnxcrsfbsf0gcpxw7bli3n19ycscpxy9974j0fck0v"))))
+ "17hi6cd4wahghh7kgvxcvmrhcqlmqag3a07id90hhzwd3zhvdxbp"))))
(build-system gnu-build-system)
(arguments
'(#:test-target "test"
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index 6c60008ec7..5e7ac66260 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -155,7 +155,7 @@ able to synchronize with CalDAV servers through vdirsyncer.")
(define-public remind
(package
(name "remind")
- (version "3.1.16")
+ (version "3.1.17")
(source
(origin
(method url-fetch)
@@ -166,7 +166,7 @@ able to synchronize with CalDAV servers through vdirsyncer.")
".")
".tar.gz"))
(sha256
- (base32 "14yavwqmimba8rdpwx3wlav9sfb0v5rcd1iyzqrs08wx07a9pdzf"))))
+ (base32 "0lgyc2j69aqqk4knywr8inz4fsnni0zq54dgqh7p4s6kzybc2mf9"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f)) ; no "check" target
diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index dcbf4c5f0b..b13b4b3a66 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -134,14 +134,14 @@ extraction from CDs.")
(define-public libcdio-paranoia
(package
(name "libcdio-paranoia")
- (version "10.2+2.0.0")
+ (version "10.2+2.0.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/libcdio/libcdio-paranoia-"
version ".tar.bz2"))
(sha256
(base32
- "1h8k8z9r75h3p697f77z9j1blwb6gf2d5rik6z2q6420my6c2ra5"))))
+ "12hfnrq7amv9qjzc92cr265m7kh0a1hpasck8cxx1gygbhqczc9k"))))
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)))
(propagated-inputs `(("libcdio" ,libcdio)))
diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index 75b9831d39..7b2cdfec5d 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -58,6 +58,7 @@
(variable "COQPATH")
(files (list "lib/coq/user-contrib")))))
(build-system ocaml-build-system)
+ (outputs '("out" "ide"))
(inputs
`(("lablgtk" ,lablgtk)
("python" ,python-2)
@@ -72,6 +73,13 @@
(lambda _
(for-each make-file-writable (find-files "."))
#t))
+ (add-after 'unpack 'remove-lablgtk-references
+ (lambda _
+ ;; This is not used anywhere, but creates a reference to lablgtk in
+ ;; every binary
+ (substitute* '("config/coq_config.mli" "configure.ml")
+ ((".*coqideincl.*") ""))
+ #t))
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -88,6 +96,23 @@
"-j" (number->string (parallel-job-count))
"world")))
(delete 'check)
+ (add-after 'install 'remove-duplicate
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ ;; These are exact copies of the version without the .opt suffix.
+ ;; Remove them to save 35 MiB in the result
+ (delete-file (string-append bin "/coqtop.opt"))
+ (delete-file (string-append bin "/coqidetop.opt")))
+ #t))
+ (add-after 'install 'install-ide
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (ide (assoc-ref outputs "ide")))
+ (mkdir-p (string-append ide "/bin"))
+ (rename-file (string-append out "/bin/coqide")
+ (string-append ide "/bin/coqide")))
+ #t))
(add-after 'install 'check
(lambda _
(with-directory-excursion "test-suite"
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c7da8b9556..ae7e7a64cc 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19816,6 +19816,33 @@ Emacs that integrate with major modes like Org-mode.")
(home-page "https://github.com/hlissner/emacs-doom-themes")
(license license:expat)))
+(define-public emacs-modus-themes
+ (package
+ (name "emacs-modus-themes")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/protesilaos/modus-themes.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "15g63675c5df2p0kk2sqj2c8qriyh69lcbggknqlaxapr13giz4x"))))
+ (build-system emacs-build-system)
+ (home-page "https://gitlab.com/protesilaos/modus-themes")
+ (synopsis "Emacs themes designed for colour-contrast accessibility")
+ (description
+ "This is a set of accessible themes for GNU Emacs. The contrast ratio
+between foreground and background values should always be >= 7:1, which
+conforms with the WCAG AAA accessibility standard.
+
+The Modus themes project consists of two standalone items, one where dark text
+is cast on a light backdrop (Modus Operandi) and another where light text is
+displayed against a dark background (Modus Vivendi).")
+ (license license:gpl3+)))
+
(define-public emacs-elixir-mode
(package
(name "emacs-elixir-mode")
@@ -20046,9 +20073,9 @@ fish-completion. It can be used in both Eshell and M-x shell.")
(license license:gpl3+))))
(define-public emacs-telega
- (let ((commit "56aef884921d99e5170d5425dbe0fce645620511")
+ (let ((commit "6184e76990db395bea02f7b5d3169e746111e1ad")
(revision "2")
- (version "0.4.4"))
+ (version "0.5.2"))
(package
(name "emacs-telega")
(version (git-version version revision commit))
@@ -20060,7 +20087,7 @@ fish-completion. It can be used in both Eshell and M-x shell.")
(commit commit)))
(sha256
(base32
- "0a8k3j20nz4xwswg9qp9xpaakk3q3ibiz8mkryk92zmrdmaah5mi"))
+ "1kfmmfc9dv3r2wxm1njflgas51qm0j8sj7yr7vfvwaz5sz7p121b"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
@@ -20142,15 +20169,17 @@ fish-completion. It can be used in both Eshell and M-x shell.")
(add-after 'emacs-build 'emacs-make-autoloads
(assoc-ref emacs:%standard-phases 'make-autoloads)))))
(propagated-inputs
- `(("emacs-visual-fill-column" ,emacs-visual-fill-column)))
+ `(("emacs-visual-fill-column" ,emacs-visual-fill-column)
+ ("ffmpeg" ,ffmpeg) ; mp4/gif support.
+ ("libwebp" ,libwebp))) ; sticker support.
(native-inputs
`(("tdlib" ,tdlib)
("emacs" ,emacs-minimal)
("python" ,python)))
(synopsis "GNU Emacs client for the Telegram messenger")
(description
- "Telega is full-featured, unofficial client for the Telegram messaging
-platform for GNU Emacs.")
+ "Telega is a full-featured, unofficial GNU Emacs-based client for the
+Telegram messaging platform.")
(home-page "https://github.com/zevlg/telega.el")
(license license:gpl3+))))
diff --git a/gnu/packages/imagemagick.scm b/gnu/packages/imagemagick.scm
index 6e10c323e8..e6a178713a 100644
--- a/gnu/packages/imagemagick.scm
+++ b/gnu/packages/imagemagick.scm
@@ -170,7 +170,7 @@ script.")
(define-public graphicsmagick
(package
(name "graphicsmagick")
- (version "1.3.32")
+ (version "1.3.33")
(source
(origin
(method url-fetch)
@@ -182,8 +182,7 @@ script.")
"GraphicsMagick/" (version-major+minor version)
"/GraphicsMagick-" version ".tar.xz")))
(sha256
- (base32
- "1qclp9i31idpcbbqswmnq2q11lmv0a7cvdb1y72xcky8sshaahmq"))))
+ (base32 "0y67dl6xbk1pxndppa93hhlq9i6bpcjw39gb4i8hnn1klqqb630k"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index 39c22262c1..49612425fb 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -104,7 +104,7 @@ that are shared between @command{go-ipfs/commands} and its rewrite
(define-public gx
(package
(name "gx")
- (version "0.14.1")
+ (version "0.14.2")
(source
(origin
(method git-fetch)
@@ -113,8 +113,7 @@ that are shared between @command{go-ipfs/commands} and its rewrite
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32
- "0pfx2p59xdbmqzfbgaf8xvlnzh8m05hkg596glq5kvl8ib65i4ha"))))
+ (base32 "048bx6khzcwxnvz3lf7kgp6fkg8mxqcqchxh0jxm9fg2iwizsi0k"))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/whyrusleeping/gx"))
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 4476e5a4ad..761e75072d 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -174,14 +174,14 @@ spreadsheets and presentations.")
(define-public libwpd
(package
(name "libwpd")
- (version "0.10.2")
+ (version "0.10.3")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/libwpd/libwpd/"
"libwpd-" version "/libwpd-" version ".tar.xz"))
(sha256 (base32
- "0436gnidx45a9vx114hhh216jrh57mqb9zyssyjfadagmyz6hgrj"))))
+ "02fx8bngslcj7i5g1gx2kiign4vp09wrmp5wpvix9igxcavb0r94"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--disable-werror")))
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 96e15ebaac..a6f3b4cea6 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1678,7 +1678,7 @@ external rate conversion.")
(define-public iptables
(package
(name "iptables")
- (version "1.6.2")
+ (version "1.8.4")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1686,7 +1686,7 @@ external rate conversion.")
version ".tar.bz2"))
(sha256
(base32
- "0crp0lvh5m2f15pr8cw97h8yb8zjj10x95zj06j46cr68vx2vl2m"))))
+ "0z0mgs1ghvn3slc868mgbf2g26njgrzcy5ggyb5w4i55j1a3lflr"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -5233,14 +5233,16 @@ re-use code and to avoid re-inventing the wheel.")
(define-public libnftnl
(package
(name "libnftnl")
- (version "1.1.4")
+ (version "1.1.5")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://netfilter.org/libnftnl/"
"libnftnl-" version ".tar.bz2"))
(sha256
- (base32 "087dfc2n4saf2k68hyi4byvgz5grwpw5kfjvmkpn3wmd8y1riiy8"))))
+ (base32 "1wqlxf76bkqf3qhka9sw32qhb2ni20q1k6rn3iril2kw482lvpk6"))
+ (patches
+ (search-patches "libnftnl-dont-check-NFTNL_FLOWTABLE_SIZE.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
@@ -5257,15 +5259,16 @@ used by nftables.")
(define-public nftables
(package
(name "nftables")
- (version "0.9.2")
+ (version "0.9.3")
(source
(origin
(method url-fetch)
- (uri (string-append "http://www.nftables.org/projects/nftables"
- "/files/nftables-" version ".tar.bz2"))
+ (uri (list (string-append "mirror://netfilter.org/nftables/nftables-"
+ version ".tar.bz2")
+ (string-append "https://www.nftables.org/projects/nftables"
+ "/files/nftables-" version ".tar.bz2")))
(sha256
- (base32
- "1x8kalbggjq44j4916i6vyv1rb20dlh1dcsf9xvzqsry2j063djw"))))
+ (base32 "0y6vbqp6x8w165q65h4n9sba1406gaz0d4744gqszbm7w9f92swm"))))
(build-system gnu-build-system)
(arguments `(#:configure-flags
'("--disable-man-doc"))) ; FIXME: Needs docbook2x.
@@ -5276,7 +5279,7 @@ used by nftables.")
("libnftnl" ,libnftnl)
("readline" ,readline)))
(native-inputs `(("pkg-config" ,pkg-config)))
- (home-page "http://www.nftables.org")
+ (home-page "https://www.nftables.org")
(synopsis "Userspace utility for Linux packet filtering")
(description "nftables is the project that aims to replace the existing
{ip,ip6,arp,eb}tables framework. Basically, this project provides a new packet
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 555fe70de4..1dcc013a7a 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -555,15 +555,14 @@ Extension (MIME).")
(define-public bogofilter
(package
(name "bogofilter")
- (version "1.2.4")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://sourceforge/bogofilter/bogofilter-"
- version "/bogofilter-"
- version ".tar.bz2"))
- (sha256
- (base32
- "1d56n2m9inm8gnzm88aa27xl2a7sp7aff3484vmflpqkinjqf0p1"))))
+ (version "1.2.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/bogofilter/bogofilter-stable/"
+ "bogofilter-" version ".tar.xz"))
+ (sha256
+ (base32 "1sl9xrnnlk2sn8gmibhn8li09vnansjbxb9l1182qmgz7cvs2j1j"))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -576,14 +575,14 @@ Extension (MIME).")
#t)))))
(native-inputs `(("flex" ,flex)))
(inputs `(("bdb" ,bdb)))
- (home-page "http://bogofilter.sourceforge.net/")
+ (home-page "https://bogofilter.sourceforge.io/")
(synopsis "Mail classifier based on a Bayesian filter")
(description
"Bogofilter is a mail filter that classifies mail as spam or ham
(non-spam) by a statistical analysis of the message's header and
content (body). The program is able to learn from the user's classifications
and corrections. It is based on a Bayesian filter.")
- (license gpl2)))
+ (license gpl3+)))
(define-public offlineimap
(package
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 54f2638f57..134fe7ed51 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -3924,7 +3924,7 @@ sample library.")
(string-map (lambda (c)
(if (char=? c #\.)
#\_ c)) version)))))
- (file-name (string-append name "-" version "-checkout"))
+ (file-name (git-file-name name version))
(sha256
(base32
"1nninz8qyqlxxjdnrm79y3gr3056pga9l2fsqh674jd3cjvafya3"))))
diff --git a/gnu/packages/patches/libnftnl-dont-check-NFTNL_FLOWTABLE_SIZE.patch b/gnu/packages/patches/libnftnl-dont-check-NFTNL_FLOWTABLE_SIZE.patch
new file mode 100644
index 0000000000..df0571bf2b
--- /dev/null
+++ b/gnu/packages/patches/libnftnl-dont-check-NFTNL_FLOWTABLE_SIZE.patch
@@ -0,0 +1,47 @@
+From: Tobias Geerinckx-Rice <me@tobias.gr>
+Date: Tue, 10 Dec 2019 16:20:40 +0100
+Subject: gnu: libnftnl: Don't check NFTNL_FLOWTABLE_SIZE.
+
+Taken verbatim from the upstream commit[0] directly following the 1.1.5
+release.
+
+[0]: https://git.netfilter.org/libnftnl/commit/?id=b2388765e0c4405442faa13845419f6a35d0134c
+
+From b2388765e0c4405442faa13845419f6a35d0134c Mon Sep 17 00:00:00 2001
+From: Phil Sutter <phil@nwl.cc>
+Date: Mon, 2 Dec 2019 18:29:56 +0100
+Subject: tests: flowtable: Don't check NFTNL_FLOWTABLE_SIZE
+
+Marshalling code around that attribute has been dropped by commit
+d1c4b98c733a5 ("flowtable: remove NFTA_FLOWTABLE_SIZE") so it's value is
+lost during the test.
+
+Assuming that NFTNL_FLOWTABLE_SIZE will receive kernel support at a
+later point, leave the test code in place but just comment it out.
+
+Fixes: d1c4b98c733a5 ("flowtable: remove NFTA_FLOWTABLE_SIZE")
+Signed-off-by: Phil Sutter <phil@nwl.cc>
+Acked-by: Pablo Neira Ayuso <pablo@netfilter.org>
+---
+ tests/nft-flowtable-test.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/tests/nft-flowtable-test.c b/tests/nft-flowtable-test.c
+index 3edb00d..8ab8d4c 100644
+--- a/tests/nft-flowtable-test.c
++++ b/tests/nft-flowtable-test.c
+@@ -33,9 +33,11 @@ static void cmp_nftnl_flowtable(struct nftnl_flowtable *a, struct nftnl_flowtabl
+ if (nftnl_flowtable_get_u32(a, NFTNL_FLOWTABLE_USE) !=
+ nftnl_flowtable_get_u32(b, NFTNL_FLOWTABLE_USE))
+ print_err("Flowtable use mismatches");
++#if 0
+ if (nftnl_flowtable_get_u32(a, NFTNL_FLOWTABLE_SIZE) !=
+ nftnl_flowtable_get_u32(b, NFTNL_FLOWTABLE_SIZE))
+ print_err("Flowtable size mismatches");
++#endif
+ if (nftnl_flowtable_get_u32(a, NFTNL_FLOWTABLE_FLAGS) !=
+ nftnl_flowtable_get_u32(b, NFTNL_FLOWTABLE_FLAGS))
+ print_err("Flowtable flags mismatches");
+--
+cgit v1.2.1
+
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 03dddcde43..9fac87648a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14327,24 +14327,15 @@ such as figshare or Zenodo.")
(define-public python-semver
(package
(name "python-semver")
- (version "2.7.9")
+ (version "2.9.0")
(source
- (origin
- (method url-fetch)
- (uri (pypi-uri "semver" version))
- (sha256
- (base32
- "0hhgqppchv59rqj0yzi1prdg2nfsywqmjsqy2rycyxm0hvxmbyqz"))))
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "semver" version))
+ (sha256
+ (base32
+ "183kg1rhzz3hqizvphkd8hlbf1zxfx8737zhfkmqzxi71jmdw7pd"))))
(build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-test-requirements
- (lambda _
- (substitute* "setup.py"
- ;; Our Python is new enough.
- (("'virtualenv<14\\.0\\.0'") "'virtualenv'"))
- #t)))))
(native-inputs
`(("python-tox" ,python-tox)
("python-virtualenv" ,python-virtualenv)))
@@ -14564,14 +14555,14 @@ user's @file{~/Trash} directory.")
(define-public python-yapf
(package
(name "python-yapf")
- (version "0.24.0")
+ (version "0.29.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "yapf" version))
(sha256
(base32
- "0anwby0ydmyzcsgjc5dn1ryddwvii4dq61vck447q0n96npnzfyf"))))
+ "1pj3xzblmbssshi889b6n9hwqbjpabw6j0fimlng2sshd3226bki"))))
(build-system python-build-system)
(home-page "https://github.com/google/yapf")
(synopsis "Formatter for Python code")
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 75c0092064..a385e62630 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2018, 2019 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2019 Brett Gilio <brettg@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -828,20 +829,21 @@ of VT100 terminal.")
(define-public python-blessings
(package
(name "python-blessings")
- (version "1.6.1")
+ (version "1.7")
(source
(origin
(method url-fetch)
(uri (pypi-uri "blessings" version))
(sha256
(base32
- "1smngy65p8mi62lgm04icasx22v976szhs2aq95y2ljmi1srb4bl"))))
+ "0z8mgkbmisxs10rz88qg46l1c9a8n08k8cy2iassal2zh16qbrcq"))))
(build-system python-build-system)
(arguments
- ;; TODO: For py3, 2to2 is used to convert the code, but test-suite fails
+ ;; FIXME: Test suite is unable to detect TTY conditions.
`(#:tests? #f))
(native-inputs
- `(("python-nose" ,python-nose)))
+ `(("python-nose" ,python-nose)
+ ("python-six" ,python-six)))
(home-page "https://github.com/erikrose/blessings")
(synopsis "Python module to manage terminal color, styling, and
positioning")
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 6d91989b19..10d864348c 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -553,13 +553,13 @@ netcat implementation that supports TLS.")
(package
(name "python-acme")
;; Remember to update the hash of certbot when updating python-acme.
- (version "0.40.1")
+ (version "1.0.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "acme" version))
(sha256
(base32
- "1z2zibs9lyxi5gxw9bny1127bjliwsp476kai1wnnnwd8238dgrk"))))
+ "1hl62dnh8zsipa5azzpy5kwgjgb5vflinhna1fsn7rcchhpz223a"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -610,7 +610,7 @@ netcat implementation that supports TLS.")
(uri (pypi-uri "certbot" version))
(sha256
(base32
- "1l8h7ggq75h59246mmzigmjr5jvzi29hihrnz9aiqh6g8hq1pj4d"))))
+ "0aih7sir5byy8ah9lrgzwcaga7hjw98qj8bb1pxzzzqrvcqjvf46"))))
(build-system python-build-system)
(arguments
`(,@(substitute-keyword-arguments (package-arguments python-acme)
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 1c2228c426..6d780dc8cd 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -456,14 +456,14 @@ The peer-to-peer VPN implements a Layer 2 (Ethernet) network between the peers
(define-public wireguard
(package
(name "wireguard")
- (version "0.0.20191127")
+ (version "0.0.20191212")
(source (origin
(method url-fetch)
(uri (string-append "https://git.zx2c4.com/WireGuard/snapshot/"
"WireGuard-" version ".tar.xz"))
(sha256
(base32
- "01ixdhbvx5yiq07msd60f98685wdksss4pfhdn1d8r25z2k80kkx"))))
+ "0wdhl7i4zkb7yf0jj03ig2ks7bsfz9if8x9dy6r2523s1ww1imxh"))))
(build-system gnu-build-system)
(outputs '("out" ; The WireGuard userspace tools
"kernel-patch")) ; A patch to build Linux with WireGuard support
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 1fbd3dcb7a..749bc06fa9 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4194,8 +4194,8 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
(package-with-python2 python-feedparser))
(define-public guix-data-service
- (let ((commit "af1324855e1ecaf9b1dd7afcc714d09aaa38f081")
- (revision "6"))
+ (let ((commit "156b7eea7e7d538e332d8cfcf482c5ebec0a25c0")
+ (revision "7"))
(package
(name "guix-data-service")
(version (string-append "0.0.1-" revision "." (string-take commit 7)))
@@ -4207,7 +4207,7 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
(file-name (git-file-name name version))
(sha256
(base32
- "1qxs1sbyx894njw4f898wzc5shjj85h9kgz95p8mq1acmazhlhkv"))))
+ "1cg7jzk7pabfp3mgnkpycasv7fs522xp3nqdvna1y76aif3pd3zh"))))
(build-system gnu-build-system)
(arguments
'(#:modules ((guix build utils)
@@ -4251,6 +4251,7 @@ CDF, Atom 0.3, and Atom 1.0 feeds.")
"guix-data-service-process-branch-updated-mbox"
"guix-data-service-process-job"
"guix-data-service-process-jobs"
+ "guix-data-service-manage-build-servers"
"guix-data-service-query-build-servers"))
#t)))
(delete 'strip)))) ; As the .go files aren't compatible