summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2020-09-15 10:47:16 +0530
committerArun Isaac <arunisaac@systemreboot.net>2020-10-12 11:41:40 +0530
commit93922eecc9f8dec90dca8fdf1df163db42c196e5 (patch)
treef14dfa50912b18974668992ae6c14b2b1217b4d0 /gnu
parent460ab99665604bded06b5af2d2a7ca9ea7f64adb (diff)
downloadguix-patches-93922eecc9f8dec90dca8fdf1df163db42c196e5.tar
guix-patches-93922eecc9f8dec90dca8fdf1df163db42c196e5.tar.gz
gnu: rust-flate2-1.0: Remove minor version from variable name.
* gnu/packages/crates-io.scm (rust-flate2-1.0): Rename to rust-flate2-1.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm20
-rw-r--r--gnu/packages/sequoia.scm2
2 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index d597596887..6df9c8a0f8 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -5100,7 +5100,7 @@ and arithmetic.")
(("rust-adler32" ,rust-adler32-1)
("rust-byteorder" ,rust-byteorder-1)
("rust-gzip-header" ,rust-gzip-header-0.3)
- ("rust-flate2" ,rust-flate2-1.0))))))
+ ("rust-flate2" ,rust-flate2-1))))))
(define-public rust-defmac-0.2
(package
@@ -7183,7 +7183,7 @@ cross platform API.")
"A procedural macro to insert @code{flame::start_guard(_)} calls.")
(license license:asl2.0)))
-(define-public rust-flate2-1.0
+(define-public rust-flate2-1
(package
(name "rust-flate2")
(version "1.0.14")
@@ -12138,7 +12138,7 @@ by inspecting the system for user preference.")
(("rust-chrono" ,rust-chrono-0.4)
("rust-dtoa" ,rust-dtoa-0.4)
("rust-encoding" ,rust-encoding-0.2)
- ("rust-flate2" ,rust-flate2-1.0)
+ ("rust-flate2" ,rust-flate2-1)
("rust-image" ,rust-image-0.20)
("rust-itoa" ,rust-itoa-0.4)
("rust-linked-hash-map" ,rust-linked-hash-map-0.4)
@@ -14707,7 +14707,7 @@ Foundation framework.")
("rust-scroll" ,rust-scroll-0.10)
("rust-parity-wasm" ,rust-parity-wasm-0.41)
("rust-uuid" ,rust-uuid-0.8)
- ("rust-flate2" ,rust-flate2-1.0)
+ ("rust-flate2" ,rust-flate2-1)
("rust-crc32fast" ,rust-crc32fast-1)
("rust-indexmap" ,rust-indexmap-1))))
(home-page "https://github.com/gimli-rs/object")
@@ -14733,7 +14733,7 @@ writing object file formats.")
(arguments
`(#:skip-build? #t
#:cargo-inputs
- (("rust-flate2" ,rust-flate2-1.0)
+ (("rust-flate2" ,rust-flate2-1)
("rust-goblin" ,rust-goblin-0.0)
("rust-parity-wasm" ,rust-parity-wasm-0.40)
("rust-scroll" ,rust-scroll-0.9)
@@ -23717,8 +23717,8 @@ cryptographic implementations.")
("rust-quote" ,rust-quote-1))
#:cargo-development-inputs
(("rust-anyhow" ,rust-anyhow-1.0)
- ("rust-flate2" ,rust-flate2-1.0)
;("rust-insta" ,rust-insta-0.12)
+ ("rust-flate2" ,rust-flate2-1)
("rust-rayon" ,rust-rayon-1)
("rust-ref-cast" ,rust-ref-cast-1.0)
("rust-regex" ,rust-regex-1)
@@ -23948,7 +23948,7 @@ cryptographic implementations.")
("rust-regex-syntax" ,rust-regex-syntax-0.6)
("rust-serde" ,rust-serde-1)
("rust-serde-derive" ,rust-serde-derive-1)
- ("rust-flate2" ,rust-flate2-1.0)
+ ("rust-flate2" ,rust-flate2-1)
("rust-serde-json" ,rust-serde-json-1)
("rust-fnv" ,rust-fnv-1)
("rust-bitflags" ,rust-bitflags-1)
@@ -25104,7 +25104,7 @@ backed applications.")
("rust-tokio-uds" ,rust-tokio-uds-0.2))
#:cargo-development-inputs
(("rust-env-logger" ,rust-env-logger-0.5)
- ("rust-flate2" ,rust-flate2-1.0)
+ ("rust-flate2" ,rust-flate2-1)
("rust-futures-cpupool" ,rust-futures-cpupool-0.1)
("rust-http" ,rust-http-0.1)
("rust-httparse" ,rust-httparse-1.3)
@@ -25202,7 +25202,7 @@ backed applications.")
("rust-tokio-timer" ,rust-tokio-timer-0.2))
#:cargo-development-inputs
(("rust-env-logger" ,rust-env-logger-0.4)
- ("rust-flate2" ,rust-flate2-1.0)
+ ("rust-flate2" ,rust-flate2-1)
("rust-futures-cpupool" ,rust-futures-cpupool-0.1)
("rust-http" ,rust-http-0.1)
("rust-httparse" ,rust-httparse-1.3)
@@ -28545,8 +28545,8 @@ implementation that works everywhere, even WASM!")
(arguments
`(#:cargo-inputs
(("rust-bzip2" ,rust-bzip2-0.3)
- ("rust-flate2" ,rust-flate2-1.0)
("rust-crc32fast" ,rust-crc32fast-1)
+ ("rust-flate2" ,rust-flate2-1)
("rust-podio" ,rust-podio-0.1)
("rust-time" ,rust-time-0.1))
#:cargo-development-inputs
diff --git a/gnu/packages/sequoia.scm b/gnu/packages/sequoia.scm
index b0ee264d5e..8f2b351031 100644
--- a/gnu/packages/sequoia.scm
+++ b/gnu/packages/sequoia.scm
@@ -83,7 +83,7 @@
("rust-dirs" ,rust-dirs-2.0)
;;("rust-failure" included
("rust-filetime" ,rust-filetime-0.2)
- ("rust-flate2" ,rust-flate2-1.0)
+ ("rust-flate2" ,rust-flate2-1)
("rust-fs2" ,rust-fs2-0.4)
("rust-futures" ,rust-futures-0.1)
("rust-http" ,rust-http-0.1)