summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorng0 <ng0@libertad.pw>2016-12-26 20:53:40 +0000
committerLeo Famulari <leo@famulari.name>2016-12-26 19:13:27 -0500
commit91426243f15696c38fbe84d3885a71f45911217f (patch)
tree9fd9eff74117f4f80414f38f4f1e111f14f02b85 /gnu
parent9916ef8bb6e83855c2a7a4e972747610b410a3ed (diff)
downloadguix-patches-91426243f15696c38fbe84d3885a71f45911217f.tar
guix-patches-91426243f15696c38fbe84d3885a71f45911217f.tar.gz
gnu: awesome: Update to 4.0.
* gnu/packages/wm.scm (awesome): Update to 4.0. [source]: Adjust URL. [inputs]: Add xcb-util-xrm and libxkbcommon. * gnu/packages/patches/awesome-reproducible-png.patch: Adjust patch. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/patches/awesome-reproducible-png.patch4
-rw-r--r--gnu/packages/wm.scm12
2 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/patches/awesome-reproducible-png.patch b/gnu/packages/patches/awesome-reproducible-png.patch
index 0fae65bc71..d8e92c70f9 100644
--- a/gnu/packages/patches/awesome-reproducible-png.patch
+++ b/gnu/packages/patches/awesome-reproducible-png.patch
@@ -7,8 +7,8 @@ See <https://wiki.debian.org/ReproducibleBuilds/TimestampsInPNG>.
set(ALL_ICONS ${ALL_ICONS} ${output})
add_custom_command(
-- COMMAND ${CONVERT_EXECUTABLE} ${input} ${ARGN} ${output}
-+ COMMAND ${CONVERT_EXECUTABLE} +set date:create +set date:modify -define png:exclude-chunk=time ${input} ${ARGN} ${output}
+- COMMAND ${CONVERT_EXECUTABLE} ${input} -strip ${ARGN} ${output}
++ COMMAND ${CONVERT_EXECUTABLE} +set date:create +set date:modify -define png:exclude-chunk=time ${input} -strip ${ARGN} ${output}
OUTPUT ${output}
DEPENDS ${input}
VERBATIM)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 46a8c3f873..6713560c5f 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -9,7 +9,7 @@
;;; Copyright © 2016 Al McElrath <hello@yrns.org>
;;; Copyright © 2016 Carlo Zancanaro <carlo@zancanaro.id.au>
;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
+;;; Copyright © 2016 ng0 <ng0@libertad.pw>
;;; Copyright © 2016 doncatnip <gnopap@gmail.com>
;;; Copyright © 2016 Ivan Vilata i Balaguer <ivan@selidor.net>
;;;
@@ -497,15 +497,15 @@ experience.")
(define-public awesome
(package
(name "awesome")
- (version "3.5.9")
+ (version "4.0")
(source
(origin (method url-fetch)
(uri (string-append
- "https://awesome.naquadah.org/download/awesome-"
- version ".tar.xz"))
+ "https://github.com/awesomeWM/awesome-releases/raw/"
+ "master/awesome-" version ".tar.xz"))
(sha256
(base32
- "0kynair1ykr74b39a4gcm2y24viial64337cf26nhlc7azjbby67"))
+ "0czkcz67sab63gf5m2p2pgg05yinjx60hfb9rfyzdkkg28q9f02w"))
(modules '((guix build utils)
(srfi srfi-19)))
(snippet
@@ -538,6 +538,7 @@ experience.")
("libxcb" ,libxcb)
("libxcursor" ,libxcursor)
("libxdg-basedir" ,libxdg-basedir)
+ ("libxkbcommon" ,libxkbcommon)
("lua" ,lua)
("lua-lgi",lua-lgi)
("pango" ,pango)
@@ -547,6 +548,7 @@ experience.")
("xcb-util-image" ,xcb-util-image)
("xcb-util-keysyms" ,xcb-util-keysyms)
("xcb-util-renderutil" ,xcb-util-renderutil)
+ ("xcb-util-xrm" ,xcb-util-xrm)
("xcb-util-wm" ,xcb-util-wm)))
(arguments
`(;; Let compression happen in our 'compress-documentation' phase so that