summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-07-12 12:35:56 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-07-12 17:39:49 +0300
commit908b680a5f213620c19c157223b45ccf3e534ade (patch)
treeb4e626b4aa28cb66b081adf38e78139a870b7c61 /gnu
parent9173cb522ddc4f31f21948cee3fb214fd67ef616 (diff)
downloadguix-patches-908b680a5f213620c19c157223b45ccf3e534ade.tar
guix-patches-908b680a5f213620c19c157223b45ccf3e534ade.tar.gz
gnu: python-attrs: Remove test deadlines on riscv64-linux.
* gnu/packages/python-xyz.scm (python-attrs)[arguments]: When building for riscv64-linux remove the hypothesis test deadlines.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c28b0675ad..f146746058 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19000,6 +19000,15 @@ from the header, as well as section details and data available.")
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
+ ,@(if (target-riscv64?)
+ ;; TODO: Remove the conditional on staging.
+ `((add-after 'unpack 'remove-test-hypothesis-deadlines
+ (lambda _
+ (substitute* "tests/test_make.py"
+ (("assume, given") "assume, given, settings")
+ (("( +)@given" all spaces)
+ (string-append spaces "@settings(deadline=None)\n" all))))))
+ '())
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?