summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-05 17:56:08 +0200
committerMarius Bakke <marius@gnu.org>2022-09-07 17:36:42 +0200
commit9046adf8efa3d33a2a9123786be4788d02cf131a (patch)
tree15b2f71bc143ab9d1168ae353a10feef0ba49608 /gnu
parent6ba66072e0a58fa10e8fe17f694558009bc5b482 (diff)
downloadguix-patches-9046adf8efa3d33a2a9123786be4788d02cf131a.tar
guix-patches-9046adf8efa3d33a2a9123786be4788d02cf131a.tar.gz
gnu: python-cfgv: Update to 3.3.1.
* gnu/packages/python-xyz.scm (python-cfgv): Update to 3.3.1. [arguments]: Respect TESTS? keyword in check phase. [native-inputs]: Remove PYTHON-COVERAGE and PYTHON-COVDEFAULTS.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 75070c8b82..a73f07ece3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22577,7 +22577,7 @@ Let's Encrypt.")
(define-public python-cfgv
(package
(name "python-cfgv")
- (version "3.1.0")
+ (version "3.3.1")
(source
(origin
;; There are no tests in the PyPI tarball.
@@ -22587,16 +22587,17 @@ Let's Encrypt.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1vvkkqw92sak4b28bpscpppq483amy52ch2yqy1i2m23q7xjkabx"))))
+ (base32 "1pci97cmn3v45sfch9s3lshidrl0309ls9byidic0l8drkwnkwcj"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
- (invoke "pytest" "-vv"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv")))))))
(native-inputs
- (list python-covdefaults python-coverage python-pytest))
+ (list python-pytest))
(home-page "https://github.com/asottile/cfgv")
(synopsis "Configuration validation library")
(description