summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-04-02 23:14:13 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-04-02 23:25:18 +0200
commit8d89d3c9bf7cacd9c79b4aacf348044d4fe7800b (patch)
treebcfb5070f67a12bb3f7707028b7065ef68486987 /gnu
parent6f6b0ea0d4761dd6c468d209a10f4420fcadd886 (diff)
downloadguix-patches-8d89d3c9bf7cacd9c79b4aacf348044d4fe7800b.tar
guix-patches-8d89d3c9bf7cacd9c79b4aacf348044d4fe7800b.tar.gz
gnu: pidgin: Update to 2.14.2.
* gnu/packages/messaging.scm (pidgin): Update to 2.14.2. [source]: Remove pidgin-vv-gst.patch. * gnu/packages/patches/pidgin-vv-gst.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/messaging.scm8
-rw-r--r--gnu/packages/patches/pidgin-vv-gst.patch48
3 files changed, 3 insertions, 54 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 0d472072ae..26976f73cd 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1525,7 +1525,6 @@ dist_patch_DATA = \
%D%/packages/patches/picard-fix-id3-rename-test.patch \
%D%/packages/patches/picprog-non-intel-support.patch \
%D%/packages/patches/pidgin-add-search-path.patch \
- %D%/packages/patches/pidgin-vv-gst.patch \
%D%/packages/patches/pinball-const-fix.patch \
%D%/packages/patches/pinball-cstddef.patch \
%D%/packages/patches/pinball-missing-separators.patch \
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 388e7f2ead..e8b67c03bc 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -788,7 +788,7 @@ authentication.")
(define-public pidgin
(package
(name "pidgin")
- (version "2.14.1")
+ (version "2.14.2")
(source
(origin
(method url-fetch)
@@ -796,11 +796,9 @@ authentication.")
(string-append "mirror://sourceforge/pidgin/Pidgin/"
version "/pidgin-" version ".tar.gz"))
(sha256
- (base32 "1c4dzxg9c3d9zfqqa7jwijj9rv9fm6w95igmpljwy88lxq7v5w11"))
+ (base32 "19r297ynxizdj357ihmy0sgpgfikdzblkszlwlqnsr3lvbjhhsg1"))
(patches
- (search-patches
- "pidgin-add-search-path.patch"
- "pidgin-vv-gst.patch"))
+ (search-patches "pidgin-add-search-path.patch"))
(modules '((guix build utils)))
(snippet
'(begin
diff --git a/gnu/packages/patches/pidgin-vv-gst.patch b/gnu/packages/patches/pidgin-vv-gst.patch
deleted file mode 100644
index e0553dd119..0000000000
--- a/gnu/packages/patches/pidgin-vv-gst.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-Name: Gary Kramlich
-Date: 2020-07-12
-Source: https://keep.imfreedom.org/pidgin/pidgin/rev/39ac50435cfb
-
-diff --git a/libpurple/mediamanager.c b/libpurple/mediamanager.c
---- a/libpurple/mediamanager.c
-+++ b/libpurple/mediamanager.c
-@@ -2231,6 +2231,7 @@
- purple_media_manager_unregister_gst_device(PurpleMediaManager *manager,
- GstDevice *device)
- {
-+#ifdef USE_VV
- GList *i;
- gchar *name;
- gchar *device_class;
-@@ -2277,6 +2278,7 @@
-
- g_free(name);
- g_free(device_class);
-+#endif /* USE_VV */
- }
-
- static gboolean
-@@ -2304,7 +2306,7 @@
- static void
- purple_media_manager_init_device_monitor(PurpleMediaManager *manager)
- {
--#if GST_CHECK_VERSION(1, 4, 0)
-+#if GST_CHECK_VERSION(1, 4, 0) && defined(USE_VV)
- GstBus *bus;
- GList *i;
-
-@@ -2334,6 +2336,7 @@
- PurpleMediaElementType type)
- {
- GList *result = NULL;
-+#ifdef USE_VV
- GList *i;
-
- for (i = manager->priv->elements; i; i = i->next) {
-@@ -2347,6 +2350,7 @@
- result = g_list_prepend(result, info);
- }
- }
-+#endif /* USE_VV */
-
- return result;
- }