summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-05 16:52:27 +0200
committerMarius Bakke <marius@gnu.org>2022-09-07 17:36:41 +0200
commit8d5637103fab0ce69e55d88bdc929f903ac58edd (patch)
tree0942d321e25de6077308761ecbcad643bd4d8346 /gnu
parent379e66b64be3f45f30fab0b8798dfbde16e434f4 (diff)
downloadguix-patches-8d5637103fab0ce69e55d88bdc929f903ac58edd.tar
guix-patches-8d5637103fab0ce69e55d88bdc929f903ac58edd.tar.gz
gnu: python-et-xmlfile: Update to 1.1.0.
* gnu/packages/python-xyz.scm (python-et-xmlfile): Update to 1.1.0. [source]: Switch to HG-FETCH. [arguments]: Use G-expression and respect TESTS? keyword.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 14 insertions, 9 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b058704172..d292f329b0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2574,20 +2574,25 @@ downloaded, or download a strip for a particular date or index, if possible.")
(define-public python-et-xmlfile
(package
(name "python-et-xmlfile")
- (version "1.0.1")
+ (version "1.1")
(source
(origin
- (method url-fetch)
- (uri (pypi-uri "et_xmlfile" version))
+ ;; Use a checkout because the PyPI archive does not contain tests.
+ (method hg-fetch)
+ (uri (hg-reference
+ (url "https://foss.heptapod.net/openpyxl/et_xmlfile")
+ (changeset version)))
+ (file-name (string-append name "-" version "-checkout"))
(sha256
- (base32
- "0nrkhcb6jdrlb6pwkvd4rycw34y3s931hjf409ij9xkjsli9fkb1"))))
+ (base32 "09r8rjc5bhkqrm5c4n9jrlvad8vrvbyswl9g0wrc1qc7nzh9mpw7"))))
(build-system python-build-system)
(arguments
- `(#:phases (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (invoke "pytest"))))))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv")))))))
(native-inputs
(list python-pytest python-lxml)) ;used for the tests
(home-page "https://bitbucket.org/openpyxl/et_xmlfile")