summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-21 19:18:20 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-29 17:28:39 +0100
commit8ce52a25bcdf4d547c589e95371697c6f440888f (patch)
tree650a67bf7c948e928c33d0d162137a877df78434 /gnu
parent8fe3694990b9d7809cfc1e6832b1a920ea0af164 (diff)
downloadguix-patches-8ce52a25bcdf4d547c589e95371697c6f440888f.tar
guix-patches-8ce52a25bcdf4d547c589e95371697c6f440888f.tar.gz
gnu: hplip: Install PPDs into a separate output.
* gnu/packages/cups.scm (hplip)[outputs]: Add a :ppd output. [arguments]: Install the .ppd files there.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cups.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index bfe24027fb..6365961699 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -446,6 +446,7 @@ should only be used as part of the Guix cups-pk-helper service.")
"locatedriverdir = $(pkglibexecdir)\n"))
#t))))
(build-system gnu-build-system)
+ (outputs (list "out" "ppd"))
(home-page "https://developers.hp.com/hp-linux-imaging-and-printing")
(synopsis "HP printer drivers")
(description
@@ -473,6 +474,8 @@ should only be used as part of the Guix cups-pk-helper service.")
(assoc-ref %outputs "out") "/lib/cups/filter")
,(string-append "--with-cupsbackenddir="
(assoc-ref %outputs "out") "/lib/cups/backend")
+ ,(string-append "--with-hpppddir="
+ (assoc-ref %outputs "ppd") "/share/ppd/HP")
,(string-append "--with-icondir="
(assoc-ref %outputs "out") "/share/applications")
,(string-append "--with-systraydir="
@@ -534,7 +537,7 @@ should only be used as part of the Guix cups-pk-helper service.")
(add-before 'configure 'fix-build-with-python-3.8
(lambda* (#:key inputs #:allow-other-keys)
(let ((python (assoc-ref inputs "python")))
- ;; XXX: The configure script of looks for Python headers in the
+ ;; XXX: The configure script looks for Python headers in the
;; wrong places as of version 3.20.3. Help it by adding the
;; include directory on C_INCLUDE_PATH.
(when python