summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-07-09 19:16:05 -0500
committerEric Bavier <bavier@member.fsf.org>2015-09-10 03:21:55 -0500
commit8b45993235ce1ad71e4038452d6e7b4b063ce448 (patch)
tree7644b049ede4eaf49b153e97140c144d0d836286 /gnu
parentbb1ba6b8f75c6b5b6cd23edf7c36068211a96c93 (diff)
downloadguix-patches-8b45993235ce1ad71e4038452d6e7b4b063ce448.tar
guix-patches-8b45993235ce1ad71e4038452d6e7b4b063ce448.tar.gz
gnu: Add perl-finance-quote.
* gnu/packages/web.scm (perl-finance-quote): New variable. * gnu/packages/patches/perl-finance-quote-unuse-mozilla-ca.patch: New patch. * gnu-system.am (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/patches/perl-finance-quote-unuse-mozilla-ca.patch15
-rw-r--r--gnu/packages/web.scm33
2 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/patches/perl-finance-quote-unuse-mozilla-ca.patch b/gnu/packages/patches/perl-finance-quote-unuse-mozilla-ca.patch
new file mode 100644
index 0000000000..5f37bb0ba7
--- /dev/null
+++ b/gnu/packages/patches/perl-finance-quote-unuse-mozilla-ca.patch
@@ -0,0 +1,15 @@
+Rather than unconditionally using Mozilla's CA certificates, let the user tell
+LWP's UserAgent where to find certificates with the PERL_LWP_SSL_CA_FILE,
+HTTPS_CA_FILE, PERL_LWP_SSL_CA_PATH, or HTTPS_CA_DIR environment variables
+instead.
+
+--- Finance-Quote-1.37/lib/Finance/Quote/Tiaacref.pm.orig 2015-02-01 13:24:41.000000000 -0600
++++ Finance-Quote-1.37/lib/Finance/Quote/Tiaacref.pm 2015-07-07 20:09:47.278885944 -0500
+@@ -30,7 +30,6 @@
+ package Finance::Quote::Tiaacref;
+ require 5.005;
+ require LWP::Protocol::https;
+-require Mozilla::CA;
+
+ use strict;
+
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index f3c6638378..3e89a728d6 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1673,6 +1673,39 @@ with Encode::decode(locale => $string).")
which can be used to parse directory listings.")
(home-page "http://search.cpan.org/~gaas/File-Listing/")))
+(define-public perl-finance-quote
+ (package
+ (name "perl-finance-quote")
+ (version "1.37")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://cpan.metacpan.org/authors/id/E/EC/ECOCODE/"
+ "Finance-Quote-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1b6pbh7f76fb5sa4f0lhx085xy55pprz5v7z7li7pqiyw7i4f4bf"))
+ (patches (list
+ (search-patch "perl-finance-quote-unuse-mozilla-ca.patch")))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-datetime" ,perl-datetime)
+ ("perl-html-parser" ,perl-html-parser)
+ ("perl-html-tableextract" ,perl-html-tableextract)
+ ("perl-html-tree" ,perl-html-tree)
+ ("perl-http-cookies" ,perl-http-cookies)
+ ("perl-http-message" ,perl-http-message)
+ ("perl-json" ,perl-json)
+ ("perl-libwww" ,perl-libwww)
+ ("perl-lwp-protocol-https" ,perl-lwp-protocol-https)
+ ("perl-uri" ,perl-uri)))
+ (home-page "http://search.cpan.org/dist/Finance-Quote")
+ (synopsis "Stock and mutual fund quotes")
+ (description
+ "Finance::Quote gets stock quotes from various internet sources, including
+Yahoo! Finance, Fidelity Investments, and the Australian Stock Exchange.")
+ (license l:gpl2)))
+
(define-public perl-gssapi
(package
(name "perl-gssapi")