summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-04-16 10:07:52 +0200
committerAndreas Enge <andreas@enge.fr>2014-04-16 10:07:52 +0200
commit8a79ec41e8bec04af4f889a4fdf2b25e3641f12c (patch)
treed384d6686967285f444cba4888dc57f6d4dfe1bd /gnu
parent8b32a70b239b608638bd98f536eb05baa6b740f9 (diff)
downloadguix-patches-8a79ec41e8bec04af4f889a4fdf2b25e3641f12c.tar
guix-patches-8a79ec41e8bec04af4f889a4fdf2b25e3641f12c.tar.gz
gnu: Add clucene.
* gnu/packages/rdf.scm (clucene): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/rdf.scm34
1 files changed, 33 insertions, 1 deletions
diff --git a/gnu/packages/rdf.scm b/gnu/packages/rdf.scm
index 22cfc2e257..c9364de6f1 100644
--- a/gnu/packages/rdf.scm
+++ b/gnu/packages/rdf.scm
@@ -17,11 +17,12 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages rdf)
- #:use-module ((guix licenses) #:select (lgpl2.0+ lgpl2.1+))
+ #:use-module ((guix licenses) #:select (lgpl2.0+ lgpl2.1 lgpl2.1+))
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
+ #:use-module (gnu packages boost)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
#:use-module (gnu packages pkg-config)
@@ -60,6 +61,37 @@ Turtle 2013, N-Quads, N-Triples 1.1, Atom 1.0, RSS 1.0, GraphViz DOT,
HTML and JSON.")
(license lgpl2.1+))) ; or any choice of gpl2+ or asl2.0
+(define-public clucene
+ (package
+ (name "clucene")
+ (version "2.3.3.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/clucene/"
+ "clucene-core-unstable/2.3/clucene-core-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1arffdwivig88kkx685pldr784njm0249k0rb1f1plwavlrw9zfx"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("boost" ,boost) ; could also use bundled copy
+ ("zlib" ,zlib)))
+ (arguments
+ `(#:test-target "cl_test"
+ #:tests? #f)) ; Tests do not compile, as TestIndexSearcher.cpp uses
+ ; undeclared usleep. After fixing this, one needs to run
+ ; "make test" in addition to "make cl_test", then
+ ; SimpleTest fails.
+ ; Notice that the library appears to be unmaintained
+ ; with no reaction to bug reports.
+ (home-page "http://clucene.sourceforge.net/")
+ (synopsis "C text indexing and searching library")
+ (description "CLucene is a high-performance, scalable, cross platform,
+full-featured indexing and searching API. It is a port of the very popular
+Java Lucene text search engine API to C++.")
+ (license lgpl2.1)))
+
(define-public soprano
(package
(name "soprano")