summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-09-22 22:22:43 +0200
committerMarius Bakke <marius@gnu.org>2021-09-23 12:05:53 +0200
commit855e34d44f02c80850434be12714726385e47dc3 (patch)
treef4d74058a1080ff0e507e69ac71286c611810acc /gnu
parent06f47e0256c45aca3b65efb9718b14f9ee669709 (diff)
downloadguix-patches-855e34d44f02c80850434be12714726385e47dc3.tar
guix-patches-855e34d44f02c80850434be12714726385e47dc3.tar.gz
gnu: LLVM, Clang: Update to 12.0.1.
* gnu/packages/patches/clang-12-tools-extra-directory.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/llvm.scm (llvm-12, clang-runtime-12): Update to 12.0.1. (clang-12): Likewise. Remove obsolete patch.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/llvm.scm12
-rw-r--r--gnu/packages/patches/clang-12-tools-extra-directory.patch16
3 files changed, 5 insertions, 24 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 5bbac17c13..8327f5c6c8 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -920,7 +920,6 @@ dist_patch_DATA = \
%D%/packages/patches/clang-9.0-libc-search-path.patch \
%D%/packages/patches/clang-10.0-libc-search-path.patch \
%D%/packages/patches/clang-11.0-libc-search-path.patch \
- %D%/packages/patches/clang-12-tools-extra-directory.patch \
%D%/packages/patches/clang-runtime-asan-build-fixes.patch \
%D%/packages/patches/clang-runtime-esan-build-fixes.patch \
%D%/packages/patches/clang-runtime-9-libsanitizer-mode-field.patch \
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 3805f4e107..de964b020d 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -480,14 +480,14 @@ output), and Binutils.")
(define-public llvm-12
(package
(name "llvm")
- (version "12.0.0")
+ (version "12.0.1")
(source
(origin
(method url-fetch)
(uri (llvm-uri "llvm" version))
(sha256
(base32
- "0l4b79gwfvxild974aigcq1yigypjsk2j5p59syhl6ksd744gp29"))))
+ "1pzx9zrmd7r3481sbhwvkms68fwhffpp4mmz45dgrkjpyl2q96kx"))))
(build-system cmake-build-system)
(outputs '("out" "opt-viewer"))
(native-inputs
@@ -542,22 +542,20 @@ of programming tools as well as libraries with equivalent functionality.")
(define-public clang-runtime-12
(clang-runtime-from-llvm
llvm-12
- "0d444qihq9jhqnfv003cr704v363va72zl6qaw2algj1c85cva45"))
+ "1950rg294izdwkaasi7yjrmadc9mzdd5paf0q63jjcq2m3rdbj5l"))
(define-public clang-12
(clang-from-llvm llvm-12 clang-runtime-12
- "1vd9rhhrd8ghdg111lac7w8by71y9l14yh5zxfijsm6lj4p4avp2"
+ "0px4gl27az6cdz6adds89qzdwb1cqpjsfvrldbz9qvpmphrj34bf"
#:patches '("clang-11.0-libc-search-path.patch")
#:tools-extra
(origin
(method url-fetch)
(uri (llvm-uri "clang-tools-extra"
(package-version llvm-12)))
- (patches
- (search-patches "clang-12-tools-extra-directory.patch"))
(sha256
(base32
- "0p3dzr0qa7mar83y66xa5m5apynf6ia0lsdsq6axwnm64ysy0hdd")))))
+ "1r9a4fdz9ci58b5z2inwvm4z4cdp6scrivnaw05dggkxz7yrwrb5")))))
(define-public clang-toolchain-12
(make-clang-toolchain clang-12))
diff --git a/gnu/packages/patches/clang-12-tools-extra-directory.patch b/gnu/packages/patches/clang-12-tools-extra-directory.patch
deleted file mode 100644
index 0a236da26e..0000000000
--- a/gnu/packages/patches/clang-12-tools-extra-directory.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Help CMake locate the "tools-extra" directory.
-
-Taken from <https://bugs.llvm.org/show_bug.cgi?id=49990#c3>.
-
-diff --git a/clang-tools-extra/clangd/quality/CompletionModel.cmake b/clang-tools-extra/clangd/quality/CompletionModel.cmake
---- a/clangd/quality/CompletionModel.cmake
-+++ b/clangd/quality/CompletionModel.cmake
-@@ -5,7 +5,7 @@
- # will define a C++ class called ${cpp_class} - which may be a
- # namespace-qualified class name.
- function(gen_decision_forest model filename cpp_class)
-- set(model_compiler ${CMAKE_SOURCE_DIR}/../clang-tools-extra/clangd/quality/CompletionModelCodegen.py)
-+ set(model_compiler ${CMAKE_CURRENT_LIST_DIR}/quality/CompletionModelCodegen.py)
-
- set(output_dir ${CMAKE_CURRENT_BINARY_DIR})
- set(header_file ${output_dir}/${filename}.h)