summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBonfaceKilz <me@bonfacemunyoki.com>2021-04-14 23:54:59 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-04-15 11:12:22 +0300
commit81b361fdd410d9318ab73cfd8e4742f82ad0ab96 (patch)
tree2d0f7b441c598c666f8e4597168ed9a9649f829b /gnu
parent5c2e4711a7c42310907a0e501c31d9d5b4a835dc (diff)
downloadguix-patches-81b361fdd410d9318ab73cfd8e4742f82ad0ab96.tar
guix-patches-81b361fdd410d9318ab73cfd8e4742f82ad0ab96.tar.gz
gnu: Add python-pytest-helpers-namespace.
* gnu/packages/python-check.scm (python-pytest-helpers-namespace): New variable. Co-authored-by: jgart <jgart@dismail.de> Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-check.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index bde836a931..b68f23a220 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -374,6 +375,39 @@ provides a shortcut to testing all code and documentation for a given
sub-package.")
(license license:bsd-3)))
+(define-public python-pytest-helpers-namespace
+ (package
+ (name "python-pytest-helpers-namespace")
+ (version "2021.3.24")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-helpers-namespace" version))
+ (sha256
+ (base32
+ "0pyj2d45zagmzlajzqdnkw5yz8k49pkihbydsqkzm413qnkzb38q"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ ;; Make the installed plugin discoverable by Pytest.
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-vv"))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest-6)
+ ("python-setuptools" ,python-setuptools) ; needs setuptools >= 50.3.2
+ ("python-setuptools-scm" ,python-setuptools-scm)
+ ("python-setuptools-declarative-requirements"
+ ,python-setuptools-declarative-requirements)))
+ (home-page "https://github.com/saltstack/pytest-helpers-namespace")
+ (synopsis "Pytest Helpers Namespace Plugin")
+ (description "Pytest Helpers Namespace Plugin provides a helpers pytest
+namespace which can be used to register helper functions without requiring
+someone to import them in their actual tests to use them.")
+ (license license:asl2.0)))
+
(define-public python-pytest-openfiles
(package
(name "python-pytest-openfiles")