summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndy Tai <lichengtai@gmail.com>2021-03-13 14:43:49 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-03-13 14:43:49 +0100
commit80a4b150fc6b8d8a387744f1957979c95240f79d (patch)
tree10c2c892bdecc9b675cb36c062ecada7360e63ba /gnu
parentde84dfbed56a7015337e2cdf64092d476a0635c7 (diff)
downloadguix-patches-80a4b150fc6b8d8a387744f1957979c95240f79d.tar
guix-patches-80a4b150fc6b8d8a387744f1957979c95240f79d.tar.gz
gnu: terminator: Update to 2.1.0.
* gnu/packages/gnome.scm (terminator): Update to 2.1.0. [inputs]: Add python, python-dbus, python-notify2. [arguments]: Add a phase to handle Python DBus. Disable tests. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm63
1 files changed, 38 insertions, 25 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d2881dbec6..b795cae145 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -10839,19 +10839,20 @@ advanced image management tool")
(define-public terminator
(package
(name "terminator")
- (version "1.92")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/gnome-" name "/" name "/"
- "releases/download/v" version "/"
- name "-" version ".tar.gz"))
- (sha256
- (base32
- "1wbkfp0nk6x9bcwi681zy30qmrp4h754sdz6b7hi9j22mmvdd50z"))))
+ (version "2.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/gnome-terminator/terminator/"
+ "releases/download/v" version "/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1vap4li2i24l1iz2q4b8wvhj8flamarf18xcmzq5ik2vzcrisbjy"))))
(build-system python-build-system)
(native-inputs
`(("gettext" ,gettext-minimal)
- ("glib:bin" ,glib "bin") ; for glib-compile-resources
+ ("glib:bin" ,glib "bin") ; for glib-compile-resources
("gobject-introspection" ,gobject-introspection)
("intltool" ,intltool)
("pkg-config" ,pkg-config)
@@ -10863,33 +10864,45 @@ advanced image management tool")
("dbus-glib" ,dbus-glib)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("gtk+" ,gtk+)
+ ("python" ,python-wrapper)
+ ("python-dbus" ,python-dbus)
+ ("python-notify2" ,python-notify2)
("python-pycairo" ,python-pycairo)
("python-pygobject" ,python-pygobject)
("vte" ,vte)))
(propagated-inputs
`(("python-configobj" ,python-configobj)))
(arguments
- `(#:imported-modules ((guix build glib-or-gtk-build-system)
+ ;; One test out of 28 fails due to dbus-python and python-notify; skip
+ ;; tests.
+ `(#:tests? #f
+ #:imported-modules ((guix build glib-or-gtk-build-system)
,@%python-build-system-modules)
#:modules ((guix build python-build-system)
((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
(guix build utils))
#:phases
(modify-phases %standard-phases
- (add-after
- 'install 'wrap-program
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((prog (string-append (assoc-ref outputs "out")
- "/bin/terminator"))
- (pylib (string-append (assoc-ref outputs "out")
- "/lib/python"
- ,(version-major+minor
- (package-version python))
- "/site-packages")))
- (wrap-program prog
- `("PYTHONPATH" = (,(getenv "PYTHONPATH") ,pylib))
- `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))
- #t)))
+ (add-after 'unpack 'handle-dbus-python
+ (lambda _
+ ;; python-dbus cannot be found but it's really there. See
+ ;; https://github.com/SpotlightKid/jack-select/issues/2
+ (substitute* "setup.py"
+ (("'dbus-python',") ""))
+ #t))
+ (add-after 'install 'wrap-program
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((prog (string-append (assoc-ref outputs "out")
+ "/bin/terminator"))
+ (pylib (string-append (assoc-ref outputs "out")
+ "/lib/python"
+ ,(version-major+minor
+ (package-version python))
+ "/site-packages")))
+ (wrap-program prog
+ `("PYTHONPATH" = (,(getenv "PYTHONPATH") ,pylib))
+ `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))
+ #t)))
(add-after 'wrap-program 'glib-or-gtk-wrap
(assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
(home-page "https://gnome-terminator.org/")