summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorpricly_yellow <pricly_yellow@dismail.de>2021-03-30 11:31:17 +0000
committerEfraim Flashner <efraim@flashner.co.il>2021-04-01 10:53:05 +0300
commit7e0e98aed6d9c9003d09ce156602a74b48b01d66 (patch)
tree79ae9b6146dcb501369fd00221e6c3a358ecd013 /gnu
parent3772f95dc7bca694446121e1cef9bf4d78bfba55 (diff)
downloadguix-patches-7e0e98aed6d9c9003d09ce156602a74b48b01d66.tar
guix-patches-7e0e98aed6d9c9003d09ce156602a74b48b01d66.tar.gz
gnu: waybar: Update to 0.9.5.
* gnu/packages/wm.scm (waybar): Update to 0.9.5. [inputs]: Replace fmt-6 with fmt, spdlog-1.7 with spdlog. * gnu/packages/logging.scm (spdlog-1.7): Remove variable. * gnu/packages/pretty-print.scm (fmt-6): Same. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/logging.scm16
-rw-r--r--gnu/packages/pretty-print.scm13
-rw-r--r--gnu/packages/wm.scm8
3 files changed, 4 insertions, 33 deletions
diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
index b879fecebc..6a4975e435 100644
--- a/gnu/packages/logging.scm
+++ b/gnu/packages/logging.scm
@@ -214,19 +214,3 @@ library.")
;; spdlog is under Expat license, but the bundled fmt library in
;; "include/spdlog/fmt/bundled" is under BSD 2 clause license.
(license (list license:expat license:bsd-2))))
-
-(define-public spdlog-1.7
- (package
- (inherit spdlog)
- (name "spdlog")
- (version "1.7.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/gabime/spdlog")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1ryaa22ppj60461hcdb8nk7jwj84arp4iw4lyw594py92g4vnx3j"))))))
diff --git a/gnu/packages/pretty-print.scm b/gnu/packages/pretty-print.scm
index af02fd91a9..4662a1e717 100644
--- a/gnu/packages/pretty-print.scm
+++ b/gnu/packages/pretty-print.scm
@@ -189,19 +189,6 @@ to @code{IOStreams}.")
;; The library is bsd-2, but documentation and tests include other licenses.
(license (list bsd-2 bsd-3 psfl))))
-(define-public fmt-6
- (package
- (inherit fmt)
- (name "fmt")
- (version "6.2.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://github.com/fmtlib/fmt/releases/download/"
- version "/fmt-" version ".zip"))
- (sha256
- (base32 "06l8g59frbsbwj15kg6x2bbn6p8yidh6wzsigdhbdjncvm1agzll"))))))
-
(define-public source-highlight
(package
(name "source-highlight")
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index d3c76d7988..4df1af27cb 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1569,7 +1569,7 @@ modules for building a Wayland compositor.")
(define-public waybar
(package
(name "waybar")
- (version "0.9.4")
+ (version "0.9.5")
(source
(origin
(method git-fetch)
@@ -1578,10 +1578,10 @@ modules for building a Wayland compositor.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "038vnma7y7z81caywp45yr364bc1aq8d01j5vycyiyfv33nm76fy"))))
+ (base32 "1kzrgqaclfk6gcwhknxn28xl74gm5swipgn8kk8avacb4nsw1l9q"))))
(build-system meson-build-system)
(inputs `(("date" ,date)
- ("fmt" ,fmt-6)
+ ("fmt" ,fmt)
("gtk-layer-shell" ,gtk-layer-shell)
("gtkmm" ,gtkmm)
("jsoncpp" ,jsoncpp)
@@ -1590,7 +1590,7 @@ modules for building a Wayland compositor.")
("libmpdclent" ,libmpdclient)
("libnl" ,libnl)
("pulseaudio" ,pulseaudio)
- ("spdlog" ,spdlog-1.7)
+ ("spdlog" ,spdlog)
("wayland" ,wayland)))
(native-inputs
`(("gcc" ,gcc-8) ; for #include <filesystem>