summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBrett Gilio <brettg@gnu.org>2020-08-01 00:33:59 -0500
committerBrett Gilio <brettg@gnu.org>2020-08-01 00:33:59 -0500
commit7caf919c57d7fee5795abcf9b78ac86e83916269 (patch)
treed1f34e8eaa4f60a029659211f3dc267b7ddcc4e9 /gnu
parent937e1ed1a14eae78839046447dc1a506394cced8 (diff)
downloadguix-patches-7caf919c57d7fee5795abcf9b78ac86e83916269.tar
guix-patches-7caf919c57d7fee5795abcf9b78ac86e83916269.tar.gz
gnu: Add emacs-extmap.
* gnu/packages/emacs-xyz.scm (emacs-extmap): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 396de32818..80e4488961 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -24029,3 +24029,25 @@ easily. Four pre-set options are: @samp{shell}, @samp{terminal},
@samp{ansi-term}, and @samp{eshell}. You can also set your custom shell if
you use some other configuration.")
(license license:gpl3+))))
+
+(define-public emacs-extmap
+ (package
+ (name "emacs-extmap")
+ (version "1.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/doublep/extmap")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "09kia3mr4si8kn46kyiza9nl669b22vmgc70ng3mqz742lph5siw"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/doublep/extmap")
+ (synopsis "Externally-stored constant mapping for Emacs Lisp")
+ (description "A very simple package that lets you build a
+read-only, constant database that maps Emacs Lisp symbols to
+arbitrary Emacs Lisp objects.")
+ (license license:gpl3+)))